PAT A1011 World Cup Betting

PAT A1011 World Cup Betting

在这里插入图片描述

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31
wordmeaning
trophyn. 奖品
all manner of各种各样的
Lottery彩票
odds assigned概率分布
times乘以
  • 思路1:
    使用<iostream>中的max_element, 选择每行最大的累乘起来,带入公式即可

  • code1:

#include <vector>
#include <algorithm>
#include <iostream>
#include <cstdio>
using namespace std;
char sign[3] = {'W','T','L'};
vector<double> v[3];
int main(){
	double tmpin;
	for(int i = 0; i < 3; ++i){
		for(int j = 0; j < 3; ++j){
			scanf("%lf", &tmpin);
			v[i].push_back(tmpin);
		}
	}
	double interest = 1.0;
	for(int i = 0; i < 3; ++i){
		//	等价:vector<int>::iterator max = max_element(begin(v[1]), end(v[1]));	//在algorithm头文件下 
		//	vector<int>::iterator max = max_element(v[1].begin(), v[1].end());
		auto max = max_element(v[i].begin(), v[i].end()); 	//添加-std=c++11 
		//	cout << *max << max - v[0].begin();	//输出元素/位置 
		printf("%c ", sign[max-v[i].begin()]);
		interest *= *max;
	}
	//!!!:WRONG 1:不需要加0.005??? 
//	printf("%.2f", (interest*0.65 - 1) * 2 + 0.005);	//加 0.005是为了实现4舍5入
	printf("%.2f", (interest*0.65 - 1) * 2);//输出不需要lf 
	return 0;
}
  • code2: 简化
#include <algorithm>
using namespace std;
char sign[3] = {'W','T','L'};
double ans[4];
int main(){
	double tmpin;
	double interest = 1.0;
	for(int i = 0; i < 3; ++i){
		for(int j = 0; j < 3; ++j){
			scanf("%lf", &ans[j]);
		}
		auto max = max_element(ans, ans+3) ; 
		printf("%c ", sign[max-ans]);
		interest *= *max;
	}
	printf("%.2f", (interest*0.65 - 1) * 2);//输出不需要lf 
	return 0;
}

  • TIPS1: algorithm中的min_element(first, last, cmp)max_element(first, last, cmp)
    1)这两个函数都可以返回一个数组(或vector)中最大最小值的迭代器it,通过*it 就可以找到相应的元素,it - begin()即再数组中的位置
    2)最后一个参数可以是函数指针,也可以是函数对象,定义<的意义(比较规则),可省略(即按照默认:1<2)
As an AI language model, I can provide you with some guidance on how to implement a Texas Hold'em poker game in Clojure. However, I cannot write the entire code for you. Here are the general steps you can follow: 1. Define the data structures for the game, such as the deck of cards, player hands, and the community cards. 2. Write functions to shuffle the deck, deal the cards, and determine the winner of the game. 3. Implement the game logic, including the betting rounds, the flop, the turn, and the river. 4. Create a user interface for the game, which can be either a command-line interface or a graphical interface. Here is some sample Clojure code to get you started: ```clojure (def suits [:hearts :diamonds :clubs :spades]) (def ranks [:2 :3 :4 :5 :6 :7 :8 :9 :10 :J :Q :K :A]) (defn make-deck [] (for [suit suits rank ranks] {:suit suit :rank rank})) (defn shuffle-deck [deck] (shuffle deck)) (defn deal-hand [deck] (take 2 deck)) (defn deal-flop [deck] (take 3 (drop 2 deck))) (defn deal-turn [deck] (take 1 (drop 5 deck))) (defn deal-river [deck] (take 1 (drop 6 deck))) (defn evaluate-hand [hand community-cards] ;; Implement the hand evaluation logic here ) (defn determine-winner [hands community-cards] (let [evaluated-hands (map #(evaluate-hand % community-cards) hands) max-hand (apply max evaluated-hands)] (nth hands (.indexOf evaluated-hands max-hand)))) (defn play-game [] (let [deck (make-deck) shuffled-deck (shuffle-deck deck) player-hands (for [_ (range 4)] (deal-hand shuffled-deck)) flop (deal-flop shuffled-deck) turn (deal-turn shuffled-deck) river (deal-river shuffled-deck) community-cards (concat flop turn river)] (determine-winner player-hands community-cards))) ;; Example usage: (play-game) ``` This is just a basic implementation, and you will need to add more features to make it a fully functional game. Good luck!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值