PAT A1062 Talent and Virtue(同B 1015)

PAT A1062 Talent and Virtue(同B 1015)

在这里插入图片描述

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
wordmeaning
outweighs比…重 >
with respect to关于, 至于
tie相等
  • 分析:
    司马缸把人分成这几类,只有talent值和virtue值都达标(≥ L)才参与分类,否则就是不可回收垃圾

合格线:L \ 优秀线:H

peopletalentvirtuenote
sage≥ H≥ H
nobleman< H≥ H
fool man< H< Hv ≥ t
small man≥ L≥ L不满足上述三种
  • 思路1:
    输入时通过if_else筛选出各类人,并统计合格的人cnt,用4个vector存储这4类人,再按要求 ( 1.总分非增 \ 2.总分同,virtue分非增 \ 3.还同,ID递增)排序输出

  • code1:

#include <stdio.h>
#include <algorithm>
#include <vector>
using namespace std;
int n, l, h;
const int maxn = 100100;
struct stu{
	int id, virtue, talent;
}s[maxn]; 
vector<stu> sta[3];

bool cmp(stu s1, stu s2){
	if((s1.virtue + s1.talent) != (s2.virtue + s2.talent))
		return (s1.virtue + s1.talent) > (s2.virtue + s2.talent);
	else if(s1.virtue != s2.virtue)
		return s1.virtue > s2.virtue;
	else 
		return s1.id < s2.id;
}
int main(){
	scanf("%d%d%d", &n, &l, &h);
	int cnt = n;
	for(int i = 0;i < n; ++i){
		scanf("%d%d%d", &s[i].id, &s[i].virtue, &s[i].talent);
		if(s[i].virtue >= l && s[i].talent >= l){
			if(s[i].virtue >= h && s[i].talent >= h){
				sta[0].push_back(s[i]);
			}else if(s[i].virtue >= h && s[i].talent < h){
				sta[1].push_back(s[i]);
			}else if(s[i].virtue < h && s[i].talent < h && s[i].virtue >= s[i].talent){
				sta[2].push_back(s[i]);
			}else{
				sta[3].push_back(s[i]);
			}
		}else{
			cnt--;
		}
	}
	sort(sta[0].begin(), sta[0].end() , cmp);
	sort(sta[1].begin(), sta[1].end() , cmp);
	sort(sta[2].begin(), sta[2].end() , cmp);
	sort(sta[3].begin(), sta[3].end() , cmp);
	printf("%d\n", cnt);
	for(int i = 0; i < 4; ++i){
		for(int j = 0; j < sta[i].size(); ++j){
			printf("%d %d %d\n", sta[i][j].id, sta[i][j].virtue, sta[i][j].talent);  
			}
	}
	return 0;
}
  • 思路2:
    在结构体中定义其所属的类别变量,排序的时候把这个变量加进去

  • T2 code:

#include <bits/stdc++.h>
using namespace std;
struct Peo{
	int id, v, t, total;
	Peo(int _id, int _v, int _t, int _total) : id(_id), v(_v), t(_t), total(_total){}
};
vector<Peo> P[6];
bool cmp(Peo a, Peo b){
	if(a.total != b.total) return a.total > b.total;
	else if(a.v != b.v) return a.v > b.v;
	else return a.id < b.id;
}
int main(){
	int n, l, h, cnt = 0;
	scanf("%d %d %d", &n, &l, &h);
	for(int i = 0; i < n; ++i){
		int id, v_score, t_score;
		scanf("%d %d %d", &id, &v_score, &t_score);
		Peo tmp = Peo(id, v_score, t_score, v_score+t_score); 
		if(v_score >= l && t_score >= l){
			if(v_score >= h && t_score >= h){
				P[0].push_back(tmp);
			}else if(v_score >= h && t_score < h){
				P[1].push_back(tmp);
			}else if(v_score < h && t_score < h && v_score >= t_score){
				P[2].push_back(tmp);
			}else{
				P[3].push_back(tmp);
			}
			cnt++;
		}
	}
	printf("%d\n", cnt);
	for(int i = 0; i < 4; ++i){
		sort(P[i].begin(), P[i].end(), cmp);
		for(int j = 0; j < P[i].size(); ++j){
			printf("%08d %d %d\n", P[i][j].id, P[i][j].v, P[i][j].t);
		}
	}
	return 0;
} 

  • T3 code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
struct Peo
{
    int id, vg, tg, sign;
};
vector<Peo> ans;
bool cmp(Peo a, Peo b)
{
    int ta = a.vg + a.tg, tb = b.vg + b.tg;
    if(a.sign != b.sign) return a.sign > b.sign;
    else if(ta != tb) return ta > tb;
    else if(a.vg != b.vg) return a.vg > b.vg;
    else return a.id < b.id;
}
int main()
{
    int n, L, H;
    scanf("%d %d %d", &n, &L, &H);
    for(int i = 0; i < n; ++i)
    {
        int tid, tvg, ttg, tsign;
        scanf("%d %d %d", &tid, &tvg, &ttg);
        if(tvg < L || ttg < L) continue;
        if(tvg >= H && ttg >= H) tsign = 4;
        else if(ttg < H && tvg >= H) tsign = 3;
        else if(ttg < H && tvg >= ttg) tsign = 2;
        else tsign = 1;
        ans.push_back(Peo{tid, tvg, ttg, tsign});
    }
    sort(ans.begin(), ans.end(), cmp);
    printf("%d\n", ans.size());
    for(int i = 0; i < ans.size(); ++i)
    {
        printf("%08d %d %d\n", ans[i].id, ans[i].vg, ans[i].tg);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个子系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值