题目链接
The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.
The goal is to take cards in such order as to minimize the total number of scored points.
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10150 + 50205 + 10505 = 500+5000+2500 = 8000
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
15020 + 1205 + 1015 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650
题意:给你n个数字,要求不能删除两端点的数字,然后删除其他数字的代价是该数字和左右相邻数字的乘积,问把数字(除端点)删完后的最小总代价。
思路:dp【i】【j】代表区间【i,j-1】的删除完的最大价值
#include <iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn=105;
int n,a[maxn],dp[maxn][maxn];
int main()
{
scanf("%d",&n);
memset(dp,0x3f3f3f3f,sizeof(dp));
for(int i=1;i<=n;++i) scanf("%d",&a[i]),dp[i][i]=0;
for(int len=1;len<=n;++len)
{
for(int l=2;l+len-1<=n;++l)
{
int r=l+len-1;
for(int k=l;k<r;++k)
dp[l][r]=min(dp[l][r],dp[l][k]+dp[k+1][r]+a[k]*a[l-1]*a[r]);
}
}
printf("%d\n",dp[2][n]);
}