HDU2476 String painter (区间DP 较难)(*)

题目链接
Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output
A single line contains one integer representing the answer.

Sample Input
zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output
6
7

Source
2008 Asia Regional Chengdu
题意:给定两个字符串a和b,求最少需要对a进行多少次操作,才能将a变成b。每次操作时将a中任意一段变成任意一个字母所组成的段。

#include<bits/stdc++.h> 
using namespace std;
const int maxn =105;
int dp[maxn][maxn],ans[maxn];
char s1[maxn],s2[maxn]; 
int main()
{
    while(scanf("%s %s",s1+1,s2+1)!=EOF)
    {
        int n=strlen(s1+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;++i) dp[i][i]=1;
        for(int len=2;len<=n;++len)
        {
            for(int l=1;l+len-1<=n;++l)
            {
                int r=l+len-1;
                dp[l][r]=dp[l+1][r]+1;
                for(int k=l+1;k<=r;++k)
                if(s2[l]==s2[k]) dp[l][r]=min(dp[l][r],dp[l+1][k]+dp[k+1][r]);
            }
        }
        for(int i=1;i<=n;++i) ans[i]=dp[1][i];
        for(int i=1;i<=n;++i)
        {
            if(s1[i]==s2[i]) ans[i]=(i==1)?0:ans[i-1];
            else{
                for(int k=1;k<=i;++k)
                ans[i]=min(ans[i],ans[k]+dp[k+1][i]);
            }
        }
        printf("%d\n",ans[n]);
    }
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值