codeup--------6120(字符串减法------getline()函数的使用以及ascaii码的哈希)

问题 D: String Subtraction (20)

[命题人 : 外部导入]

时间限制 : 1.000 sec  内存限制 : 32 MB

解决: 942提交: 1971统计

题目描述

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S1 - S2 in one line.

样例输入 Copy

They are students.
aeiou

样例输出 Copy

Thy r stdnts.
#include <iostream>
#include <fstream>
#include <string>
using namespace std;

const int MaxN = 200;

int main()
{
#ifdef _DEBUG
    ifstream cin("data.txt");
#endif // _DEBUG

    string str, substr;
    while (getline(cin,str))
    {
        getline(cin, substr);
        bool flag[MaxN] = { false };
        for (int i = 0, size = substr.size(); i < size; ++i)
            flag[substr[i]] = true;
        for (int i = 0, size = str.size(); i < size; ++i)
            if (!flag[str[i]])
                printf("%c",str[i]);
        printf("\n");
    }

#ifdef _DEBUG
    cin.close();
    system("pause");
#endif // _DEBUG

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值