【POJ 2392】【Space Elevator】

题目:

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:一群牛要修建高楼,他们手头有n种建筑材料,之后交代建筑材料的高度,能达到的最大高度(超过就会损坏),数量,求解高楼的最大高度。

解题思路:多重背包,先对建筑材料的能承受的最大高度排序,将承受最大高度小的材料优先放置,才能使结构达到最优,高度达到最大,之后就是多重背包的模板求解。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 100005
using namespace std;
int cnt[maxn];
int dp[maxn];
struct node{
	int ht;
	int num;
	int maxx;
}co[maxn];

bool cmp(node a,node b)
{
	return a.maxx<b.maxx;
}
int main()
{
	int k;
	while(scanf("%d",&k)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=k;i++)
		{
			scanf("%d%d%d",&co[i].ht,&co[i].maxx,&co[i].num);
		}
		sort(co+1,co+1+k,cmp);
		dp[0]=1;
		int ans=0;
		for(int i=1;i<=k;i++)
		{
			memset(cnt,0,sizeof(cnt));
			for(int j=co[i].ht;j<=co[i].maxx;j++)
			{
				if(!dp[j]&&dp[j-co[i].ht]&&cnt[j-co[i].ht]+1<=co[i].num)
				{
					dp[j]=1;
					cnt[j]=cnt[j-co[i].ht]+1;
					if(ans<j) ans=j;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值