Back and Forth 递推

Problem Statement

 

Dolphin resides in two-dimensional Cartesian plane, with the positive x-axis pointing right and the positive y-axis pointing up.
Currently, he is located at the point (sx,sy). In each second, he can move up, down, left or right by a distance of 1.
Here, both the x- and y-coordinates before and after each movement must be integers.
He will first visit the point (tx,ty) where sx<tx and sy<ty, then go back to the point (sx,sy), then visit the point (tx,ty) again, and lastly go back to the point (sx,sy).
Here, during the whole travel, he is not allowed to pass through the same point more than once, except the points (sx,sy) and (tx,ty).
Under this condition, find a shortest path for him.

Constraints

 

  • −1000≤sx<tx≤1000
  • −1000≤sy<ty≤1000
  • sx,sy,tx and ty are integers.

Input

 

The input is given from Standard Input in the following format:

sx sy tx ty

Output

 

Print a string S that represents a shortest path for Dolphin.
The i-th character in S should correspond to his i-th movement.
The directions of the movements should be indicated by the following characters:

  • U: Up
  • D: Down
  • L: Left
  • R: Right

If there exist multiple shortest paths under the condition, print any of them.

Sample Input 1

 

0 0 1 2

Sample Output 1

 

UURDDLLUUURRDRDDDLLU

One possible shortest path is:

  • Going from (sx,sy) to (tx,ty) for the first time: (0,0) → (0,1) → (0,2) → (1,2)
  • Going from (tx,ty) to (sx,sy) for the first time: (1,2) → (1,1) → (1,0) → (0,0)
  • Going from (sx,sy) to (tx,ty) for the second time: (0,0) → (−1,0) → (−1,1) → (−1,2) → (−1,3) → (0,3) → (1,3) → (1,2)
  • Going from (tx,ty) to (sx,sy) for the second time: (1,2) → (2,2) → (2,1) → (2,0) → (2,−1) → (1,−1) → (0,−1) → (0,0)

Sample Input 2

 

-2 -2 1 1

Sample Output 2

 

UURRURRDDDLLDLLULUUURRURRDDDLLDL

 

 


 

 题意:海豚生活在二维坐标系中,他位于点(sx,sy)。每秒钟,它可以向上、向下、向左或向右移动1个距离。他将首先访问点(tx,ty),并且sx<tx, sy<ty,然后回到点(sx,sy),然后再次访问点(tx,ty),最后回到点sx,sy。除了点(sx,sy)和点(tx,ty)外,不能多次通过同一个点。在这种情况下,为他找到一条最短路径。


 借大神张图:但该题是先往上走 ,按图中数字顺序为:S→4→3→2→1→T→12→11→10→9→T→8→7→6→5→S

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;
const int N = 1100000;
int vis[2010][2010];
int main()
{
    int s1, t1, s2, t2;
    scanf("%d %d %d %d", &s1, &t1, &s2, &t2);
    for(int i=1;i<=(t2-t1);i++) printf("U");//使从第一个点开始走向第二个点的第一步,达到同一个y;
    for(int i=1;i<=(s2-s1);i++) printf("R");//使从第一个点开始走向第二个点的第二步,达到同一个x;
    for(int i=1;i<=(t2-t1);i++) printf("D");//从第二个点回到第一个点的第一步,达到同一个y;
    for(int i=1;i<=(s2-s1);i++) printf("L");//从第二个点回到第一个点的第二步,达到同一个x;

    printf("L"); //进行第二次, 往左走一步保证路径达到最短;
    for(int i=1;i<=(t2-t1)+1;i++) printf("U");//为了不重复走其他点且路径最短,多往上走一步;
    for(int i=1;i<=(s2-s1)+1;i++) printf("R");//同上;
    printf("D");//因为较第一次多走一步,所以需要往下回来一步,到达第二个点;
    
    //第二次,怎么从第一个点走向第二个点,相对应走多少步回到第一个点
    printf("R");//回到第一个点不重复前面且路径最短;
    for(int i=1;i<=(t2-t1)+1;i++) printf("D");    
    for(int i=1;i<=(s2-s1)+1;i++) printf("L");
    printf("U\n");
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值