O - POJ 2352树状数组

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


题意:建立二维坐标系,分别在坐标系中标出每个星星的位置,每个星星的级数 由他左下方的星星的数量决定(该星星的坐标与原点坐标围成的矩形中,包含星星的个数包括边界,不包括自己)

输出n行。第一行包0级的星星数量,第二行包 1级的星星数量,以此类推,最后一行包含N-1级的星星数量。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cmath>
#include<stack>
using namespace std;
int n, m, num[32010];
int vis[15010];

//树状数组的常规操作;
//取最后一位1;
int lowbit(int x)
{
    return x&(-x);
}
//单点更新;
void add(int x)
{
    for(int i=x; i<=32010; i+=lowbit(i))
    {
        num[i]+=1;//因为每次星星都为1个所以为+1;
    }
    return ;
}
//区间查询;
int getsum(int x)
{
    int ans = 0;
    for(int i =x; i>0; i-=lowbit(i))
    {
        ans+=num[i];
    }
    return ans;
}
int main()
{
    while(scanf("%d", &n)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            int x, y;
            scanf("%d%d", &x, &y);
            x++;//因为树状数组的区间是从1开始的;
  //(因为题目中说,在输入星星坐标时,是按照Y坐标的升序排列,Y坐标相等的恒星按X坐标的升序排列。)
            add(x);
            vis[getsum(x)]++;//每查到一次等级为fetsum(x)的星星就把标记等级的数组+1;
        }
        for(int i=1; i<=n; i++)
        {
            printf("%d\n", vis[i]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值