J - POJ 2364 RMQ

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A≤ B ≤ N), representing the range of cows from Ato B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意:n个数,q次询问,问输入区间的最值的差。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cmath>
#include<stack>
#include <map>
#include <queue>
using namespace std;
const int maxn = 50010;
int n, q, maxx[maxn][20], minn[maxn][20];

//RMQ预处理 状态转移;
void RMQ(int n)
{
    for(int j=0; j<17; j++)
    {
        for(int i=n; i>0; i--)
        {
            if(i+(1 << j)<=n)
            {
                maxx[i][j+1] = max( maxx[i][j], maxx[i+(1 << j)][j] );
                minn[i][j+1] = min( minn[i][j], minn[i+(1 << j)][j] );
            }
        }
    }
}
//求从l到r区间的最大值;
int querymax(int l, int r)
{
    if(l>r)
        return -1;
    int k = (int)(log(r-l+1.0)/log(2.0));
    return max(maxx[l][k], maxx[r- (1 << k) + 1][k]);
}
//求从l到r区间的最小值;
int querymin(int l, int r)
{
    if(l>r)
        return -1;
    int k = (int)(log(r-l+1.0)/log(2.0));
    return min(minn[l][k], minn[r- (1 << k) + 1][k]);
}
int main()
{
    while(scanf("%d%d",&n, &q)!=EOF)
    {
        memset(maxx, 0, sizeof(maxx));
        memset(minn, 0, sizeof(minn));
        int tm;
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &tm);
            maxx[i][0] = minn[i][0] = tm;
        }
        RMQ(n);
        int l, r;
        while(q--)
        {
            scanf("%d%d", &l, &r);
            printf("%d\n", querymax(l, r) - querymin(l, r));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值