HDU 多校赛 Problem D. Euler Function problem-6322

Problem Description

In number theory, Euler's totient function φ(n) counts the positive integers up to a given integer n that are relatively prime to n. It can be defined more formally as the number of integers k in the range 1≤k≤n for which the greatest common divisor gcd(n,k) is equal to 1.
For example, φ(9)=6 because 1,2,4,5,7 and 8 are coprime with 9. As another example, φ(1)=1 since for n=1 the only integer in the range from 1 to n is 1itself, and gcd(1,1)=1.
A composite number is a positive integer that can be formed by multiplying together two smaller positive integers. Equivalently, it is a positive integer that has at least one divisor other than 1 and itself. So obviously 1 and all prime numbers are not composite number.
In this problem, given integer k, your task is to find the k-th smallest positive integer n, that φ(n) is a composite number.

Input

The first line of the input contains an integer T(1≤T≤100000), denoting the number of test cases.
In each test case, there is only one integer k(1≤k≤109).

Output

For each test case, print a single line containing an integer, denoting the answer.

Sample Input

2

1

2

Sample Output

5

7

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=6322

 这是按照理解题意写的代码,打了三个表提交还是TLE

TLE:代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define N 100000001
bool prime[N];
int a[N];
int b[N];
int main() {

    int i, j;
    
    for (i = 2; i<=N; i++)
    { 
        if (i % 2) 
            prime[i] = true;
        else
            prime[i] = false;
    }
        for (i = 3; i <= sqrt(N); i++)

        {
            if (prime[i])
                for (j = i + i; j<=N; j += i) 
                    prime[j] = false;

        }
        prime[1] = true;
        prime[2] = true;

        
            a[1] = 1;
            for (i = 2; i<=N; i++)
                a[i] = i;
            for (i = 2; i<=N; i++)
                if (a[i] == i)
                    for (j = i; j<=N; j += i)
                        a[j] = a[j] / i * (i - 1);

                j = 0;
                for (int i = 1; i <=N; i++)
                {
                    if (!prime[a[i]])
                        b[++j] = i;
                }        
    int t, n;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &n);
        printf("%d\n", b[n]);
        }
    return 0;
}

 后来缩小范围测试了一组数据找到规律后就非常简单了

AC:代码

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t;
 scanf("%d", &t);
while (t--) { 
int n; scanf("%d", &n); 
if (n == 1)
printf("5\n");
 else 
printf("%d\n", n + 5); }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值