HDU_1081最大子矩阵

To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14934 Accepted Submission(s): 6980

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

Sample Output
15

题意:给你一个N*N的矩阵,问最大矩阵和为多少。
原题传送

下面给出ac代码

#include<stdio.h>
#include<algorithm>
#include<string.h> 
using namespace std;
const int N=507;
typedef long long ll;
ll sum[N][N],mn,ans,x;
int i,j,k,n;
int main(){
    while(~scanf("%d",&n))
    {

     ans=mn=0; 
     memset(sum,0,sizeof(sum));
        for(i=1;i<=n;++i)
        for(j=1;j<=n;++j)
        {
            scanf("%lld",&sum[i][j]);
            sum[i][j]+=sum[i][j-1];
       }
        for(i=1;i<=n;++i)
        {
            for(j=i;j<=n;++j)
          {
            for(mn=0,x=0,k=1;k<=n;++k)
            {
                x+=(sum[k][j]-sum[k][i-1]);
                ans=max(ans,x-mn),mn=min(mn,x);
            }
          }
        }   
        printf("%lld\n",ans);
    }
    return 0;
}

其实求最大矩阵和,有一个模板,下面给出。

#include<stdio.h>
#include<algorithm>
#include<string.h> 
using namespace std;
const int N=507;
typedef long long ll;
ll sum[N][N],mn,ans,x;
int i,j,k,n,m;
int main()
{
    scanf("%d%d",&m,&n);
    for(i=1;i<=n;++i)
    {

        for(j=1;j<=m;++j)
        {
            scanf("%lld",&sum[i][j]);
            sum[i][j]+=sum[i][j-1];
         }
     }
        for(i=1;i<=m;++i)
        {
            for(j=i;j<=m;++j)
          {
            for(mn=0,x=0,k=1;k<=n;++k)
            {
                x+=(sum[k][j]-sum[k][i-1]);
                ans=max(ans,x-mn),mn=min(mn,x);
            }
          }
        }   
    printf("%lld\n",ans);
    return 0;
}

此代码是求的N*M的矩阵的最大矩阵和,需要时可以套用。
需注意的是此代码是求得一组数据;有些同学是不是对ans,mn为什么没有初始化有疑问?
到底需不需要初始化,答案是肯定的。因为代码把他们定义成了全局变量,作为全局变量,初始值为0,sum数组也是如此,如果定义成局部变量,他们的初始值是随机分配的。
所以如果要算多组测试数据则需要对他们进行初始化,注意写到循环里面,因为每次都需要初始化。

在这里补充一个最大连续子段和的模板,但该模板仅能算出最大子段和,而不能得出该字段的L ~r(即该最大子段从第几个~第几个)。
例:-2 11 -4 13 -5 -2 他的最大连续子段和是20(11 -4 13 20)

最大连续子段和代码

#include<stdio.h>
#include<algorithm>
#include<string.h>
typedef long long ll;
using namespace std;
const int maxn=1e5+7;
ll a[maxn];
int main()
{
    ll ans,mn,sum;
    int n,i,t,j;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        ans=mn=sum=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%lld",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            sum+=a[i];
            mn=min(sum,mn);
            ans=max(ans,sum-mn);
        }
    printf("%lld ",ans);
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值