HUD6441——Find Integer

Find Integer
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1391 Accepted Submission(s): 443
Special Judge

Problem Description
people in USSS love math very much, and there is a famous math problem .
give you two integers n,a,you are required to find 2 integers b,c such that an+bn=c^n.

Input
one line contains one integer T;(1≤T≤1000000)
next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);
else print two integers -1 -1 instead.

Sample Input
1
2 3

Sample Output
4 5

**提示:**费马定理——当整数 n> 2 时,关于 x,y,z 的方程 x^n + y^n = z^n 没有正整数解,注意不能用过多文件头和万能文件头会超时
这里写图片描述


AC代码:


#include <stdio.h>
long long int n,a,b,c,z;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld %lld",&n,&a);
        if(n==2)
        {
            z=a*a;
            if(a%2)  //a为奇数
            {
                b=z/2;
                c=z/2+1;
            }
            else     //a为偶数
            {
                b=z/4-1;
                c=z/4+1;
            }
            printf("%lld %lld\n",b,c);
        }
        else if(n==1)
            printf("1 %lld\n",a+1);
        else
            printf("-1 -1\n");
    }
    return 0;
}




余生还请多多指教!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值