PAT 甲级 1038 (Recover the Smallest Number )

题目要求

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤ 1 0 4 10^4 104 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

翻译

给出一个集合,找出集合中数字拼接得到的最小的数字

代码

#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int n;
string s[10001];
bool cmp(string a,string b)
{
    return a+b < b+a;
}
int main()
{
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>s[i];
    }
    sort(s,s+n,cmp);
    string ans="";
    int i;
    for(i=0;i<n;i++) ans+=s[i];

    for(i=0;ans[i]=='0';i++);
    if(i==ans.size()) cout<<0;
    while(i<ans.size()){
        cout<<ans[i];
        i++;
    }
    system("pause");
}

思路

主要是看如何对集合中的数进行排序,这里使用两个字符串的拼接。
不如说x = 321 和y = 32,
x+y=32132 y+x=32321 可以得到后者大
return x+y<y+x即可,具体可以看上文cmp函数。
另外还需要注意如果都是0的话,直接输出0,不然的话会没有输出。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值