Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
题目大意
给出树的中序序列和后序序列,求出树的层序序列。
AC代码
#include <iostream>
#include <queue>
using namespace std;
typedef struct node{
int data;
node *lchild, *rchild;
}*BTree, BNode;
int post[50], in[50];
BTree create(int l1, int h1, int l2, int h2){
//后序序列为[l1,h1],中序序列为[l2,h2]
if(l1 > h1) return NULL;
BNode* BT = new node;
BT->data = post[h1];
int k = l2; //找到中序序列中根结点的位置
while(in[k] != BT->data) k++;
int len = k - l2;
BT->lchild = create(l1, l1 + len - 1, l2, k - 1);
BT->rchild = create(l1 + len, h1 - 1, k + 1, h2);
return BT;
}
void levelorder(BTree BT){
queue<BNode*> Q;
Q.push(BT);
int cnt = 0; //防止多输出空格
while(!Q.empty()){
BNode* top = Q.front();
Q.pop();
cnt++;
if(cnt != 1) cout<<" ";
cout<<top->data;
if(top->lchild) Q.push(top->lchild);
if(top->rchild) Q.push(top->rchild);
}
}
int main(){
int n;
cin>>n;
for(int i = 0; i < n; i++)
cin>>post[i];
for(int i = 0; i < n; i++)
cin>>in[i];
BTree BT = create(0, n - 1, 0, n - 1);
levelorder(BT);
return 0;
}