1114 Family Property(DFS求连通分量)

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 … Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

AC代码

#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;

const int maxn = 10010;
vector<int> vc[maxn]; //存放家庭关系
vector<int> member; //存放所有拥有房产者的编号 
double area[maxn]; //不动产面积 
double set[maxn]; //不动产总数 
bool vis[maxn] = {false};
struct family{
	int id, m;
	double avg_set, avg_area;
	family(int a, int b, double c, double d): id(a), m(b), avg_set(c), avg_area(d){}
};
vector<family> ans;

bool cmp(family a, family b){
	if(a.avg_area != b.avg_area)
		return a.avg_area > b.avg_area;
	else return a.id < b.id;
}

int min_id, num;
double avg1, avg2;
void DFS(int u){
	if(u < min_id) min_id = u;
	num++;
	avg1 += set[u];
	avg2 += area[u];
	vis[u] = true;
	for(int i = 0; i < vc[u].size(); i++){
		int v = vc[u][i];
		if(vis[v] == false)
			DFS(v);
	}
}
void DFSTrave(){
	for(int i = 0; i < member.size(); i++){
		int v = member[i];
		if(vis[v] == false){
			min_id = maxn, num = 0;
			avg1 = 0.0, avg2 = 0.0;
			DFS(v);
			ans.push_back(family(min_id, num, avg1 / num, avg2 / num));
		}
	}
}

int main(){
	int n, id, fa, mo, k, child;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d%d%d%d", &id, &fa, &mo, &k);
		member.push_back(id);
		if(fa != -1){
			vc[id].push_back(fa);
			vc[fa].push_back(id);
		}
		if(mo != -1){
			vc[id].push_back(mo);
			vc[mo].push_back(id);
		}
		for(int j = 0; j < k; j++){
			scanf("%d", &child);
			vc[child].push_back(id);
			vc[id].push_back(child);
		}
		scanf("%lf%lf", &set[id], &area[id]);
	}
	DFSTrave();
	sort(ans.begin(), ans.end(), cmp);
	printf("%d\n", ans.size());
	for(int i = 0; i < ans.size(); i++){
		printf("%04d %d %.3lf %.3lf\n", ans[i].id, ans[i].m, ans[i].avg_set, ans[i].avg_area);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值