1136 A Delayed Palindrome

Consider a positive integer N written in standard notation with k+1 digits a​i as ak⋯a1 a0 with 0≤ai​ < 10 for all i and ak > 0. Then N is palindromic if and only if a​i =ak−i for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome.

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

思路

由于n的位数可能多达1000位,需先将n转化为字符串再进行处理。

AC代码

#include <iostream>
#include <algorithm>
#include <string>
#include <cmath>
using namespace std;

string a, b, sum;
void add(string a, string b, string &sum){
	int i = a.size() - 1;
	int last = 0; //进位
	for(; i >= 0; i--){
		int t = a[i] - '0' + b[i] - '0' + last;
		char c = t % 10 + '0';
		sum = c + sum ;
		last = t / 10;
	}
	if(last > 0) //最高位进位
		sum = (char)(last + '0') + sum ; 
}

int main(){
	bool flag = false; //是否得到回文数
	cin>>a;
	for(int i = 0; i < 10; i++){
		for(int i = a.size() - 1; i >= 0; i--)
			b += a[i];
		if(a == b){
			flag = true;
			break;
		}
		add(a, b, sum);
		cout<<a<<" + "<<b<<" = "<<sum<<endl;
		a = sum;
		sum.clear();
		b.clear();
	}
	if(flag) cout<<a<<" is a palindromic number.";
	else cout<<"Not found in 10 iterations.";
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值