华为交换机实现不同VLAN内的互通配置(汇聚层设备作为网关)

背景如下:

如下图所示,PC1和PC2分别属于VLAN 2和VLAN 3,通过接入层设备DeviceB接入汇聚层设备DeviceA。PC3属于VLAN 4,通过接入层设备DeviceC接入汇聚层设备DeviceA。DeviceC不做任何配置,当做HUB即插即用。汇聚层设备DeviceA作为PC1、PC2和PC3的网关,实现用户PC间的互访以及和上层设备的互连。
在这里插入图片描述

操作步骤

  1. 配置接入层设备DeviceB。
    #创建VLAN。
<HUAWEI> system-view
[HUAWEI] sysname DeviceB
[DeviceB] vlan batch 2 3

#将接口加入相应VLAN。

[DeviceB] interface 10ge 1/0/2
[DeviceB-10GE1/0/2] portswitch
[DeviceB-10GE1/0/2] port link-type access
[DeviceB-10GE1/0/2] port default vlan 2
[DeviceB-10GE1/0/2] quit
[DeviceB] interface 10ge 1/0/3
[DeviceB-10GE1/0/3] portswitch
[DeviceB-10GE1/0/3] port link-type access
[DeviceB-10GE1/0/3] port default vlan 3
[DeviceB-10GE1/0/3] quit
[DeviceB] interface 10ge 1/0/1
[DeviceB-10GE1/0/1] portswitch
[DeviceB-10GE1/0/1] port link-type trunk
[DeviceB-10GE1/0/1] port trunk allow-pass vlan 2 3
[DeviceB-10GE1/0/1] quit
  1. 配置汇聚层设备DeviceA。
    #创建VLAN。
<HUAWEI> system-view
[HUAWEI] sysname DeviceA
[DeviceA] vlan batch 2 to 5

#将连接DeviceB、DeviceC的接口加入相应VLAN。

[DeviceA] interface 10ge 1/0/2
[DeviceA-10GE1/0/2] portswitch
[DeviceA-10GE1/0/2] port link-type trunk
[DeviceA-10GE1/0/2] port trunk allow-pass vlan 2 3
[DeviceA-10GE1/0/2] quit
[DeviceA] interface 10ge 1/0/3
[DeviceA-10GE1/0/3] portswitch
[DeviceA-10GE1/0/3] port link-type access
[DeviceA-10GE1/0/3] port default vlan 4
[DeviceA-10GE1/0/3] quit

#配置VLANIF接口,作为用户PC的网关。

[DeviceA] interface vlanif 2
[DeviceA-Vlanif5] ip address 192.168.2.1 24
[DeviceA-Vlanif5] quit
[DeviceA] interface vlanif 3
[DeviceA-Vlanif5] ip address 192.168.3.1 24
[DeviceA-Vlanif5] quit
[DeviceA] interface vlanif 4
[DeviceA-Vlanif5] ip address 192.168.4.1 24
[DeviceA-Vlanif5] quit

将连接上层设备的接口加入相应VLAN。

[DeviceA] interface 10ge 1/0/1
[DeviceA-10GE1/0/1] portswitch
[DeviceA-10GE1/0/1] port link-type access
[DeviceA-10GE1/0/1] port default vlan 5
[DeviceA-10GE1/0/1] quit

#配置VLANIF接口,实现内网网段到上层设备的访问。

[DeviceA] interface vlanif 5
[DeviceA-Vlanif5] ip address 192.168.5.1 24
[DeviceA-Vlanif5] quit

检查配置结果
执行命令display vlan可以查看VLAN状态,
以DeviceB为例:

[DeviceB] display vlan 2
--------------------------------------------------------------------------------
U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
MP: Vlan-mapping;               ST: Vlan-stacking;
#: ProtocolTransparent-vlan;    *: Management-vlan;
MAC-LRN: MAC-address learning;  STAT: Statistic;
BC: Broadcast; MC: Multicast;   UC: Unknown-unicast;


FWD: Forward;  DSD: Discard;
--------------------------------------------------------------------------------

VID          Ports
--------------------------------------------------------------------------------
   2         UT:10GE1/0/2(U)   10GE1/0/3(U)
             TG:10GE1/0/1(U)

VID  Type     Status  Property  MAC-LRN STAT    BC  MC  UC  Description
--------------------------------------------------------------------------------
   2 common   enable  default   enable  disable FWD FWD FWD VLAN 0002

#执行命令display port vlan,查看接口上可以通过的VLAN信息,以DeviceB的接口10GE1/0/1为例:

[DeviceB] display port vlan 10ge 1/0/1
Port                    Link Type    PVID  Trunk VLAN List                      Port Description
---------------------------------------------------------------------------------------------------------------
10GE1/0/1              trunk           1  2-3

配置脚本

• DeviceA

sysname DeviceA

vlan batch 2 to 5

interface Vlanif2
ip address 192.168.2.1 255.255.255.0

interface Vlanif3  
ip address 192.168.3.1 255.255.255.0 

interface Vlanif4  
ip address 192.168.4.1 255.255.255.0 

interface Vlanif5  
ip address 192.168.5.1 255.255.255.0  //上行出口

interface 10GE1/0/1
port link-type access
port default vlan 5

interface 10GE1/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 3

interface 10GE1/0/3
port link-type access
port default vlan 4

return

• DeviceB

sysname DeviceB

vlan batch 2 to 3

interface 10GE1/0/1
 
port link-type trunk  
port trunk allow-pass vlan 2 to 3 

interface 10GE1/0/2
port link-type access  
port default vlan 2 

interface 10GE1/0/3
port link-type access  
port default vlan 3 

return

• DeviceC

sysname DeviceC

vlan batch 4
interface 10GE1/0/1
port link-type access  
port default vlan 4

interface 10GE1/0/2
port link-type access  
port default vlan 4 

return

日常学习总结

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

保持成长

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值