PAT 1006 Sign in and Sign out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:给出n个人的id、sign in时间、sign out时间,求最早进来的人和最早出去的人的ID

#include <iostream>
#include <string>
using namespace std;

/*
    其实思路很简单,就是找到 一天当中 最先开门的那个人的 id 以及 最后锁门的 那个人的 id 就ok了
    但问题是 如何控制输入呢?这就是问题所在
*/
struct Person{
    char id[20];
    int hh, mm, ss;
}tmp, ans1, ans2; //ans1存放最早开门时间,ans2存放最晚锁门时间

bool cmp(Person node1, Person node2){ //node1时间 大于 node2时间 返回true;
    if(node1.hh != node2.hh) return node1.hh > node2.hh;
    if(node1.mm != node2.mm) return node1.mm > node2.mm;
    return node1.ss > node2.ss;
}

int main(){
    int n;
    cin >> n;
    ans1.hh = 24, ans1.mm = 60, ans1.ss = 60; //把初始开门时间 设为最大
    ans2.hh = 0,  ans2.mm = 0,  ans2.ss = 0; //把初始锁门时间 设为最小
    
    for(int i=0; i<n; i++){
        //鄙人学术过浅 并不知道scanf可以这样用
        scanf("%s %d:%d:%d", tmp.id, &tmp.hh, &tmp.mm, &tmp.ss); //scanf中是无法输入 string类型的哦 而且用cin似乎无法控制输入':' 因此要灵活运用scanf和cin
        if(cmp(tmp, ans1) == false) ans1 = tmp; //如果说 tmp时间小于ans1 那么令ans1等于tmp
        scanf("%d:%d:%d", &tmp.hh, &tmp.mm, &tmp.ss);
        if(cmp(tmp, ans2) == true)  ans2 = tmp; //如果说 tmp时间大于ans2 那么令ans2等于tmp
    }
    
    cout << ans1.id << " " << ans2.id << endl;
    return 0;
}	

贴个柳神的:
分析:将时间都转换为总秒数,最早和最迟的时间保存在变量minn和maxn中,并同时保存当前最早和最迟的人的ID,最后输出~
#include <iostream>
#include <climits>
using namespace std;
int main() {
    int n, minn = INT_MAX, maxn = INT_MIN;
    scanf("%d", &n);
    string unlocked, locked;
    for(int i = 0; i < n; i++) {
        string t;
        cin >> t;
        int h1, m1, s1, h2, m2, s2;
        scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int tempIn = h1 * 3600 + m1 * 60 + s1;
        int tempOut = h2 * 3600 + m2 * 60 + s2;
        if (tempIn < minn) {
            minn = tempIn;
            unlocked = t;
        }
        if (tempOut > maxn) {
            maxn = tempOut;
            locked = t;
        }
    }
    cout << unlocked << " " << locked;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值