PAT Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 – 01:00, the toll from 01:00 – 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
/*
    第一行输入 24个时间段 内的 每分钟的收费
    第二行 输入n,随后输入n行记录
    要找到 每个用户 通话的起始时间 开始与结束时间一定要匹配 不匹配就不会被记录
*/

#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

const int maxn = 1005;
struct Record {
    char id[21];
    int MM, dd, HH, mm;
    bool status; //status == true 表示该记录为 on-line false 表示为 off-line
}p[maxn], temp;

int toll[24]; //24个时间段分别的价位

bool cmp(Record a, Record b) {
    int s = strcmp(a.id, b.id);
    if (s != 0) return s < 0;
    else if (a.MM != b.MM) return a.MM < b.MM;
    else if (a.dd != b.dd) return a.dd < b.dd;
    else if (a.HH != b.HH) return a.HH < b.HH;
    else return a.mm < b.mm;
}

void get_ans(int on, int off, int& time, int& money) { //一定要传引用哦
    temp = p[on];
    while (temp.dd < p[off].dd || temp.HH < p[off].HH || temp.mm < p[off].mm) {
        time++; //通话总时间
        money += toll[temp.HH]; //累计 各个时间段的 费用
        temp.mm++;
        //这里的两个if一定要保证顺序,不然就会出错
        if (temp.mm >= 60) {
            temp.mm = 0;
            temp.HH++;
        }
        if (temp.HH >= 24) {
            temp.HH = 0;
            temp.dd++;
        }
    }
}

int main() {
    for (int i = 0; i < 24; i++) { //处理第一行输入 24个时间段的各段费用
        scanf("%d", &toll[i]);
    }
    int n; //n条记录
    cin >> n;
    char line[10];//临时存放on-line或off-line的输入
    for (int i = 0; i < n; i++) {
        scanf("%s", p[i].id);
        scanf("%d:%d:%d:%d", &p[i].MM, &p[i].dd, &p[i].HH, &p[i].mm);
        scanf("%s", line);
        if (!strcmp(line, "on-line")) {
            p[i].status = true;
        }
        else{
            p[i].status = false;
        }
    }

    sort(p, p + n, cmp); //按字典序排序 排完序后,每个用户的记录都是按时间顺序连续在一起的
    /*
        排完序后,就需要找配对的on-line off-line
        on-line的数组下标 与 off-line的数组下标 相差为1时才能配对 且on前off后
    */
    int on = 0, off, next; //on 和 off为配对的两条记录, next为下一个用户
    while (on < n) { //每次循环处理单个用户的所有记录
        int needPrint = 0; //表示该用户是否需要输出 (如果此用户的记录无法匹配就无需输出)
        next = on; //从当前位置寻找下一用户 (必须在on处开始,因为我们需要知道on处的 status是什么)
        while (next < n && strcmp(p[next].id, p[on].id) == 0) {
            if (needPrint == 0 && p[next].status == true) { //如果碰到该用户的 第一个on-line
                needPrint = 1; //置needPrint为1
            }//一定记住 on前off后 只有在有on的前提下 off才能与之对应
            else if (needPrint == 1 && p[next].status == false) { //直至碰到第一个 off-line
                needPrint = 2;
            }
            next++; //直到找到下一个用户
        }
        //每次next出来都是指向一个新的用户
        if (needPrint < 2) { //没有找到配对on-off 只有needPrint == 2时才有配对的on off
            on = next;
            continue; //不用输出此用户 直接去看下一个用户
        }
        
        /*能走到这里,就说明该用户有 配对的记录*/
        int Allmoney = 0; //代表每个用户总共花的钱
        printf("%s %02d\n", p[on].id, p[on].MM);
        /*
            此时next指向下一个用户的开头 那么该用户的配对记录 就是next之前的所有记录
            next - 1指向该用户最后一条记录
            最后一对是 on = next - 2 on + 1 = next - 1
        */
        while (on < next) { //寻找该用户所有配对
            while (on < next - 1 && !(p[on].status == true && p[on + 1].status == false)) { //如果不是匹配的两条记录
                on++; //让on就往下走 直至 找到一组配对的记录
            }
            off = on + 1; //得到一组配对记录 就更新off
            if (off == next) { //off指向下个用户的首记录
                on = next; //令on指向下个用户首记录 跳出循环
                break;
            }
            printf("%02d:%02d:%02d ", p[on].dd, p[on].HH, p[on].mm);
            printf("%02d:%02d:%02d ", p[off].dd, p[off].HH, p[off].mm);

            int time = 0, money = 0; //时间, 单次记录花费的金钱
            get_ans(on, off, time, money); //计算on 到 off内的时间和金钱
            Allmoney += money;
            printf("%d $%.2f\n", time, money / 100.0);
            on = off + 1; //完成一个配对,从off + 1开始找下一对
        }
        printf("Total amount: $%.2f\n", Allmoney / 100.0); //除以100是让 分转换成元
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值