F - Prime Path题后反思

F - Prime Path

本题的题意就是给定两个数m和n,每次改变一个数的个位值或十位值或百位值或千位值,使他变成一个素数,在对该素数进行前面的操作,问至少经过几次从m变到n
本题考查对bfs的理解和应用,但又和一般的最短路问题有点区别,一般的最短路问题只要到了终点就可以结束,而本题到了终点不一定是最短的,而要依次比较完每一种可能,更新每一次的路径
坑点:1不要有结束条件;
坑点:2对于同一个数字入队了就不要重复入队,可以用一个数组来标记,入队就标记为1,出队就标记0;
坑点:3用一个数组来记录最短路,先把所有值初始化为-1,如果当前数字的路径为-1或大于所求数字的路径则更新路径值
具体看代码注释

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input
3
1033 8179
1373 8017
1033 1033

Sample Output
6
7
0

代码实现

#include <stdio.h>
#include <math.h>
#include <queue>
#include <string.h>
using namespace std;

const int MAX=10050;
int su[MAX],book[MAX],num[4],m,n,temp,vis[MAX];  //book记录数字是否已经入队  //nun数组记录各个位的值 例如1234 记录1 2 3 3

//
struct  node{        //定义结构体保存当前的数字和路径
    int x,step;
}en,st;
queue<node>q;
int su_t( int n){    //判断素数 若为素数的话返回1  否则返回0
    int i,t;
    t=sqrt(n+0.0);   //开根号,(n+0.0)转换为double类型
    for (i=2;i<=t;i++){
        if (n%i==0) return 0;
    }
    return 1;
}


int main() {
    for(int i=2;i<MAX;i++) su[i]=su_t(i);    //在组数中标记下标是否为素数,素数存1 非素数存0
    int t;
    scanf("%d",&t);
    while(t--){
        memset(book,0, sizeof(book));    //初始化是否已经入队
        scanf("%d %d",&m,&n);
        if(m==n) {
            printf("0\n");               //特判,如果两数相等,则返回0
            continue;
        }

        memset(vis,-1, sizeof(vis));   //初始化路径记录值

        flag=0;
        while(!q.empty()) q.pop();    //队列清空
        st.x=m;
        st.step=0;
        book[st.x]=1;
        vis[st.x]=0;
        q.push(st);                    //头入队列
        while(!q.empty()){
            st=q.front();
            q.pop();
            book[st.x]=0;            //标记队头已经入队
            temp=st.x;
            for(int i=0;i<4;i++){   //记录该数各个位上的值
                num[i]=temp%10;
                temp/=10;
            }
            en.step=st.step+1;
            for(int i=0;i<=9;i++){        //换掉个位上的数
                en.x=i+num[1]*10+num[2]*100+num[3]*1000;
                if(vis[en.x]==-1 || vis[en.x]>en.step){  //如果该处vis值为-1或该处存储的路径值较大,则更新它
                    vis[en.x]=en.step;
                    if(su[en.x]==1&& !book[en.x]){  //如果满足条件则入队
                        book[en.x]=1;  //把入队的数标记为1
                        q.push(en);   //入队
                    }
                }

            }

            for(int i=0;i<=9;i++){      //更换十位值 ,详解参考上面注释
                en.x=num[0]+i*10+num[2]*100+num[3]*1000;
                if(vis[en.x]==-1 || vis[en.x]>en.step){
                    vis[en.x]=en.step;
                    if(su[en.x]==1 && !book[en.x]){
                        book[en.x]=1;
                        q.push(en);
                    }
                }

            }

            for(int i=0;i<=9;i++){   //更换百位值,详解参考上面注释
                en.x=num[0]+num[1]*10+i*100+num[3]*1000;
                if(vis[en.x]==-1 || vis[en.x]>en.step){
                    vis[en.x]=en.step;
                    if(su[en.x]==1 && !book[en.x]){
                        book[en.x]=1;
                        q.push(en);
                    }

                }

            }

            for(int i=1;i<=9;i++){    //更换千位值,详解参考上面注释
                en.x=num[0]+num[1]*10+num[2]*100+i*1000;
                if(vis[en.x]==-1 || vis[en.x]>en.step){
                    vis[en.x]=en.step;
                    if(su[en.x]==1 && !book[en.x]) {
                        book[en.x]=1;
                        q.push(en);
                    }
                }


            }

        }

        printf("%d\n",vis[n]);  

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值