最短路SPFA—Wormholes(POJ - 3259)

题目链接:>_>

题目:Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:

有n块地,有m个双向路,走双向路需要花费一定时间,有w个单向路,走单向路会让时间倒流一定时间。求是否可以从起点出发再回到起点,在之前从起点开始出发之前到达起点。

AC代码:

#include<stdio.h>
#include<iostream>
#include<queue>
#include<algorithm>
#include<math.h>
#include<cstring>
using namespace std;
#define ll long long
#define itn int
const int maxn = 10005,  maxm = 10005;
const ll inf = 0x3f3f3f3f;
itn n, m, cnt;
int dis[maxn], vis[maxn], head[maxm], outqueue[maxm];

struct node {
	int to, next, w;
}x[10005];
void add(int start,int endd,int w) {
	x[cnt].w = w;
	x[cnt].to = endd;
	x[cnt].next = head[start];
	head[start] = cnt++;
}
void init() {
	cnt = 0;
	memset(dis, inf, sizeof dis);
	memset(head, -1, sizeof head);
	memset(vis, 0, sizeof vis);
	memset(outqueue, 0, sizeof outqueue);
}
queue<int>q;
bool spfa() {
	q.push(1);
	dis[1] = 0;
	vis[1] = 1;
	while (!q.empty()) {
		itn u = q.front();
		q.pop();
		vis[u] = 0;
		outqueue[u]++;
		if (outqueue[u] > n)return 0;
		for (int i = head[u]; i != -1; i = x[i].next) {
			int v = x[i].to;
			if (dis[v] > dis[u] + x[i].w) {
				dis[v] = dis[u] + x[i].w;
				if (!vis[v]) {
					vis[v] = 1;
					q.push(v);
				}
			}
		}
	}
	return 1;
}

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		init();
		int y = 0;
		scanf("%d %d %d", &n, &m, &y);
		int i, j;
		int q1, q2, q3;
		for (i = 0; i < m; i++) {
			scanf("%d %d %d", &q1, &q2, &q3);
			add(q1, q2, q3);
			add(q2, q1, q3);
		}
		for (i = 0; i < y; i++) {
			scanf("%d %d %d", &q1, &q2, &q3);
			add(q1, q2, -q3);
		}
		if (spfa())cout << "NO" << endl;
		else cout << "YES" << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值