Labyrinth(树的直径)

Labyrinth

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence “Maximum rope length is X.” where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3

#.#

7 6
#######
#.#.###
#.#.###
#.#.#.#
#…#
#######
Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended.
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc
最后一段话很重要!!!(因为我就tle了好几发)
将cin挂掉同步流,C++/C和C++/gcc的区别应该在头文件的引用(反正我把cstring改成stdio.h就从tle变成ac了)

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;

int vis[1007][1007];
int viss[1007][1007];
char s[1007][1007];
int d[4][2]={0,1,1,0,0,-1,-1,0};//定义成d[][2]也会超时,应该是开了多余的栈占用了空间
int t,n,m,ans,ansn;
int ex,ey;
struct area{
	int x,y,step;
//	friend bool operator<(area a,area b){
//		return a.step >b.step ;
//	}
};

void bfs(int x,int y){
	queue<area> que;
	area e1,e2;
	e1.x =x;
	e1.y =y;
	vis[x][y]=1;
	viss[x][y]=1;
	e1.step =0;
	que.push(e1);
	ans=0;
	while(!que.empty()){
		e1=que.front();
		que.pop();
		if(e1.step >=ans){
		ans=e1.step;
		ex=e1.x ;
		ey=e1.y ;
		//cout<<"ans:"<<ans<<endl;
		//cout<<e1.x <<" "<<e1.y <<" "<<e1.step <<endl;
		}
		
		for(int i=0;i<4;i++){
			e2.x=e1.x +d[i][0];
			e2.y=e1.y +d[i][1];
			if(e2.x>=0&&e2.x<m&&e2.y>=0&&e2.y<n&&vis[e2.x][e2.y]==0&&s[e2.x][e2.y]=='.'){
				e2.step =e1.step +1;
				vis[e2.x][e2.y]=1;
				viss[e2.x][e2.y]=1;
		//		cout<<"xx:"<<e2.x<<"  yy:"<<e2.y<<" step:"<<e2.step <<endl;
				que.push(e2); 
			}
		}
		
	}
}


int main(){
	ios::sync_with_stdio(0);
	cin.tie(),cout.tie();
	cin>>t;
	while(t--){
		ansn=0;
		cin>>n>>m;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				cin>>s[i][j];
			}
		}
		memset(viss,0,sizeof(viss));
		memset(vis,0,sizeof(vis));
		int flag=0;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				if(s[i][j]=='.'&&!viss[i][j]){
					flag=1;
		//			cout<<"start:"<<i<<" "<<j<<endl;
					bfs(i,j);
					
		//			cout<<"start:"<<ex<<" "<<ey<<endl;
					memset(vis,0,sizeof(vis));
					bfs(ex,ey);
					ansn=max(ans,ansn);
				}
			}
			if(flag) break;
		}
		cout<<"Maximum rope length is "<<ans<<"."<<endl;
	}
	return 0;
}

/*
2
3 3
###
#.#
###
43 15
###########################################
####...................####################
##########.................................
#...........................###############
#...############........###################
.........##################################
#....####################..............####
#.#...#####################################
###########################################
#...............#############..........####
#######.....####...........................
#####.........##...........................
######.......###...........................
###########..### ..........................
################...........................


*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值