题目链接:http://lightoj.com/volume_showproblem.php?problem=1370
Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo's length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题目翻译:
给出n个数字的序列a[],对于每个数字ai找到一个欧拉函数值大于等于ai的数bi,求找到的所有数bi的最小值之和sum
Input
有T(T<=100)组数据,每组数据有两行,第一行给定n(n<=10000) 第二行给出长度为n的序列a[],ai的取值范围为[1,1000000]
Output
输出一个数sum
有两个做法,一种是最直接和简单的,直接欧拉函数打表,然后按照表来判断输出就行了。
另一种利用了欧拉函数的一个性质:φ(n)=n-1(n为质数),所以我们可以从ai+1开始找最小质数,记录一下就行了。
不过开始要预处理求出最大范围内的质数。(可以用线筛或者埃筛)
#include<cstdio>
const int N = 1000000 + 5;
bool prime[N];
int p[N], tot;
void init(){
for(int i = 2; i < N; i ++) prime[i] = true;
for(int i = 2; i < N; i++){
if(prime[i]) p[tot ++] = i;
for(int j = 0; j < tot && i * p[j] < N; j++){
prime[i * p[j]] = false;
if(i % p[j] == 0) break;
}
}
}
int main(){
int T,n,x;
scanf("%d",&T);
init();
for(int kcase=1;kcase<=T;kcase++){
scanf("%d",&n);
long long sum=0;
for(int i=0;i<n;++i){
scanf("%d",&x);
long long k=x+1;
while(!prime[k]) k++;
sum+=k;
}
printf("Case %d: %lld Xukha\n",kcase,sum);
}
return 0;
}