poj2115——一元线性同余方程

题目链接:http://poj.org/problem?id=2115

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;


I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

题目翻译:

一个C语言的for循环:

        for(int i=A;i!=B;i+=C)st;

其中i表示变量,ABC分别表示初值、终值和步长,st表示循环体。
要求计算当循环变量i运算在k位无符号整数体系下(运算值范围:0~2^k-1,此时,i+=c溢出后截断),循环体st会执行多少次?

输入格式

输入每组数据包括4个整数A,B,Ck

输出格式

对于每组数据,输出循环次数,如果永远不能结束,输出FOREVER

 

可以推出一个同余方程: A + Cx = B ( mod 2^k ),可以化简成 Cx = B - A ( mod 2^k),之后就是很经典的求解一元线性同余方程的问题了,可以转换成ax=b(mod n)标准形式来写(a=C,b=B-A,n=2^k),等价于ax+ny=b;

d=gcd(a,n),如果 不满足 d | b,那么无解。否则 a = a0*d,n = n0*d,原方程变为a0*x+b0*y=b/d,用扩展欧几里得可以求出解x,但是解不唯一,但都属于同一个模m剩余系,所以解为 x,x+n0,x+2*n0......,在解中找出符合条件的结果就行。

#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;
void ex_gcd(ll a,ll b,ll& d,ll& x,ll& y){
	if(!b){x=1;y=0;d=a;}
	else{ex_gcd(b,a%b,d,y,x),y-=(a/b)*x;}
}
int main(){
	ll A,B,C,a,b,c,k,x,y,d;
	while(~scanf("%lld%lld%lld%lld",&A,&B,&C,&k)){
		if(!A&&!B&&!C&&!k) break;
		ll a=C;
		ll b=B-A;
		ll n=(ll)1<<k;
		ex_gcd(a,n,d,x,y);
		if(b%d!=0) printf("FOREVER\n");
		else{
			ll res=x*(b/d);
			res=res%(n/d)+n/d;
			printf("%lld\n",res%(n/d));
		}
		
	}
	return 0;
} 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值