HDU 4282 A very hard mathematic problem

Problem Description
Haoren is very good at solving mathematic problems. Today he is working a problem like this:
Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
X^Z + Y^Z + XYZ = K
where K is another given integer.
Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
Now, it’s your turn.

Input
There are multiple test cases.
For each case, there is only one integer K (0 < K < 2^31) in a line.
K = 0 implies the end of input.

Output
Output the total number of solutions in a line for each test case.

Sample Input
9
53
6
0

Sample Output
1
1
0
  
Hint
9 = 1^2 + 2^2 + 1 * 2 * 2
53 = 2^3 + 3^3 + 2 * 3 * 3

结合方程以及题目所给k值的范围,可以大概得出y的范围为[2,50000],z的范围为[2,30];因此可以直接枚举y和z,再二分x的值,最后代入方程看是否符合即可.

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
ll poww(int n,int m)
{
	ll ans=1;
	while(m>0)  //快速幂
	{
		if(m&1) ans*=n;
		n*=n;
		m/=2;
	}
	return ans;
}
bool search(int y,int z,int k)
{
	int l=1,r=y;
	while(l<r)
	{
		int x=(l+r)/2;
		ll sum=poww(x,z)+poww(y,z)+x*y*z;
		if(sum==k){
			return true;
		}
		if(sum>k){
			r=x;
		}
		else{
			l=x+1;
		}
	}
	return false;
}
int main()
{
	int k;
	while(scanf("%d",&k)==1&&k)
	{
		int cnt=0;
		for(int y=2;y<50000&&y<=k;y++){
			for(int z=2;z<31&&poww(y,z)<k;z++){
				if(search(y,z,k)){
					cnt++;
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值