hdu 2680 Choose the best route(SPFA)

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output
1
-1

它开始会给你几个可选择的起始点,你可以求得这些点到终点各自所花时间,输出花费时间最短的用时,一开始我没多想,直接依次将所给起点一个个调用spfa求那个点的最短时间,再从这些时间中找出最小值,结果TLE了,仔细一想,我其实还可以反向建图,这样就可以找出从终点出发到各个点所需最短时间了,只需调用一遍spfa即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
int d[1005],vis[1005],G[1005][1005];
int n,m,t;
void init()
{
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			G[i][j]=inf;	
}
void spfa(int s)
{
	queue<int>q;
	memset(vis,0,sizeof(vis));
	memset(d,inf,sizeof(d));
	d[s]=0;
	vis[s]=1;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=1;i<=n;i++){
			if(G[u][i]+d[u]<d[i]&&G[u][i]!=inf){
				d[i]=G[u][i]+d[u];
				if(!vis[i]) vis[i]=1,q.push(i);
			}
		}
	}
}
int main()
{
	while(scanf("%d %d %d",&n,&m,&t)!=EOF)
	{
		init();
		int a,b,c;
		for(int i=0;i<m;i++){
			scanf("%d %d %d",&a,&b,&c);
			if(G[b][a]>c)   //不加会WA
				G[b][a]=c;
		}
		int w,s,min=inf;
		spfa(t);
		scanf("%d",&w);
		for(int i=0;i<w;i++){
			scanf("%d",&s);
			if(d[s]<min) min=d[s];
		}
		if(min==inf){
			printf("-1\n");
		}
		else{
			printf("%d\n",min);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值