hdu 1045 -Fire Net

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

 

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input

4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0

 

Sample Output

5 1 5 2 4

由于题目数据不大,直接dfs爆搜即可

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
char a[1005][1005];
int n,maxx;
bool check(int xx,int yy)
{
	for(int i=yy-1;i>=0;i--){  //从该位置这一行向后面搜,看有没有出现两个炮台在同一行并且之间也没有墙
		if(a[xx][i]=='X')      //遇到墙则退出该循环
			break;
		if(a[xx][i]=='#')      //出现并且两炮台之间又没有墙则返回false
			return false;
	}
	for(int i=xx-1;i>=0;i--){  //从该位置这一列向上面搜,看有没有出现两个炮台在同一列并且之间也没有墙
		if(a[i][yy]=='X')
			break;
		if(a[i][yy]=='#')  
			return false;			
	}
	return true;              
}
void dfs(int k,int num)
{
	if(k==n*n){  
		maxx=num>maxx?num:maxx;  //每次遍历完成都要取最大的那个炮台数
		return ;
	}
	int i=k/n;   //对应的横坐标
	int j=k%n;   //对应的纵坐标
	if(a[i][j]=='.'&&check(i,j)){  //如果这一点为空并且这一行在该位置后面没有炮台以及这一列在该位置上面也没有炮台,则执行if语句
		a[i][j]='#';               //记录该点为炮台'#'
		dfs(k+1,num+1);            //可安放炮台数num+1,并且移动位置继续搜索
		a[i][j]='.';
	}
	dfs(k+1,num);//否则该点不记录但仍然移动
}
int main()
{
	while(cin>>n&&n)
	{
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				cin>>a[i][j];
			}
		}
		int x,y,flag=1,cnt=0;
		maxx=0;
		for(int i=0;i<n&&flag;i++){
			for(int j=0;j<n&&flag;j++){
				if(a[i][j]=='.'){//按照遍历顺序找第一个空的位置cnt
					flag=0;
					break;		
				}
				cnt++;
			}
		}
		dfs(cnt,0);
		cout<<maxx<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值