HDU 2612 Find a way

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#

Sample Output

66
88
66

题意很容易理解,就是你和你的女朋友一个在Y点处而另一个再M点处,你和你女朋友可以向四个方向移动,问你们两到达同一个KFC处用时最短多少。一开始构思了半天决定调用两次dfs,每当dfs扫到KFC时再用同一个位置的二维数组记录你的步数和你女朋友步数之和。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
char a[205][205];
int vis[205][205],da[205][205];
int dx[4]={1,0,-1,0};
int dy[4]={0,1,0,-1};
int cx,cy,mx,my,n,m;
struct node
{
	int x,y,t;
};
bool judge(int xx,int yy)
{
	if(xx<0||xx>=n||yy<0||yy>=m||vis[xx][yy]||a[xx][yy]=='#'){
		return false;
	}
	return true;
}
void bfs(int x,int y)
{
	node temp,tmp;
	temp.x=x;
	temp.y=y;
	temp.t=0;
	vis[x][y]=1;
	queue<node> q;
	q.push(temp);
	while(!q.empty())
	{
		tmp=q.front();
		q.pop();
		if(a[tmp.x][tmp.y]=='@'){
			da[tmp.x][tmp.y]+=tmp.t;   //你和你女朋友步数之和
		}
		for(int i=0;i<4;i++){
			int xx=tmp.x+dx[i];
			int yy=tmp.y+dy[i];
			if(judge(xx,yy)){
				temp.x=xx;
				temp.y=yy;
				temp.t=tmp.t+1;
				vis[xx][yy]=1;
				q.push(temp);
			} 
		}
	}
}
int main()
{
	while(cin>>n>>m)
	{
		memset(da,0,sizeof(da));
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				cin>>a[i][j];
				if(a[i][j]=='Y'){
					cx=i;cy=j;
				}
				if(a[i][j]=='M'){
					mx=i;my=j;
				}
			}
		}
		memset(vis,0,sizeof(vis));
		bfs(cx,cy);
		memset(vis,0,sizeof(vis));
		bfs(mx,my);
		int minn=99999999;
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(minn>da[i][j]&&da[i][j]){   //这个坐标点有KFC时
					minn=da[i][j];
				}
			}			
		}			
		cout<<minn*11<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值