PAT_Advanced Level_1001 A+B Format(C++_模拟)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Process

这道题最大的障碍是语言不通,不过还好可以看样例猜题意~

Code

#include<bits/stdc++.h>
using namespace std;
long long a, b;
stack<int> c;
int main()
{
    cin >> a >> b;
    long long temp = a + b;
    if (temp < 0)
        cout << "-";
    temp = fabs(temp);
    if (temp == 0)
        cout << "0";
    else
    {
        while (temp >= 1)
        {
            c.push(temp % 1000);
            temp /= 1000;
        }
        int flag = 0;
        while (!c.empty())
        {
            if (flag == 0)
                printf("%d", c.top());
            else
                printf("%03d", c.top());
            c.pop();
            cout << (c.empty() ? "\n" : ",");
            flag++;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

chaoql

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值