PAT (Advanced Level) _1001 A+B Format

本文介绍了如何使用C++编程语言实现一个功能,计算两个整数a和b的和,然后将结果按照每三位数字用逗号分隔的标准格式输出。代码中包含了输入处理和不同范围结果的输出逻辑。
摘要由CSDN通过智能技术生成

题目

1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

A+B结果三个数字分一组用逗号隔开,先求和再分组

AC代码

//保留三位整数
#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;

int main()
{
    int a,b,sum;
    cin>>a>>b;
    sum = a+b;
    //cout<<sum<<endl;
    if(sum>-1000 && sum<1000)cout<<sum;    //4位数(不含)以下的直接输出
    else if(sum>-1000000 && sum<1000000){  //7位(不含)以下的,分两段
        int t = sum % 1000;
        sum /= 1000;
        cout<<sum<<","<<setfill('0')<<setw(3)<<fabs(t);
    }else{                                  //根据题目给出的范围结果最多7位数,分三段
        int t1 = sum%1000;
        sum /= 1000;
        int t2 = sum%1000;
        sum /= 1000;
        cout<<sum<<","<<setfill('0')<<setw(3)<<fabs(t2)<<","<<setfill('0')<<setw(3)<<fabs(t1);
    }

    return 0;
}
/*
输出的时候要注意第二段第三段都是 三位 正 整数
eg1:-1000000 -1000000
应该输出 -2,000,000 而不是 -2,0,0
eg2:-1000000 9
应该输出-999,991 而不是 -999,-991
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值