【PAT】1043. Is It a Binary Search Tree (25)【树的遍历】

题目描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

翻译:一个二叉搜索树(BST)是一棵根据以下特性递归定义的二叉树:
1.一个节点的左子树仅仅包括比该节点关键字小的节点。
2.一个节点的右子树仅仅包括大于等于该节点关键字的节点。
3.左子树和右子树 必须也为二叉搜索树。
如果我们交换每个节点的左右子树,则得到的数叫做镜像二叉搜索树。
现在给你一个整数关键字的数列,你需要说出它是否是二叉搜索树或是镜像二叉搜索树的先序遍历数列。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包含一个正整数N (<=1000).。接着下一行为N个整数关键字。一行内所有数字用空格隔开。

OUTPUT FORMAT

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

翻译:对于每组输入数据,如果数列是二叉搜索树或是镜像二叉搜索树的先序遍历数列则输出“YES”,如果不是就输出“NO”。如果是“YES”,第二行输出该树的后序遍历数列。一行内所有数字用空格隔开,行末尾没有多余空格。


Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8


Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8


Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO


解题思路

先构造出一棵二叉搜索树。注意判断是否为镜像树(第二个数比第一个数大)。如果构造出的树的先序遍历与给定顺序不同,则输出NO,否则就输出它的后序遍历。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,pre[1010],tree[1010][2],mirror=-1;
void createTree(int s,int root){
    if(pre[s]<pre[root]){
        if(mirror==-1)mirror=0;
        if(!tree[root][0])tree[root][0]=s;
        else createTree(s,tree[root][0]);
    }
    if(pre[s]>=pre[root]){
        if(mirror==-1)mirror=1;
        if(!tree[root][1])tree[root][1]=s;
        else createTree(s,tree[root][1]);
    }
}
int ccount=0,flag=0;
bool Preorder(int root){
    if(root!=ccount++)flag=1;
    if(mirror==0){ 
        if(tree[root][0])Preorder(tree[root][0]);
        if(tree[root][1])Preorder(tree[root][1]);
    } 
    if(mirror==1){ 
        if(tree[root][1])Preorder(tree[root][1]);
        if(tree[root][0])Preorder(tree[root][0]);
    } 
    if(flag==1)return false;
    return true;
}
int tflag=0;
void Inorder(int root){
    if(mirror==0){ 
        if(tree[root][0])Inorder(tree[root][0]);
        if(tree[root][1])Inorder(tree[root][1]);
    } 
    if(mirror==1){ 
        if(tree[root][1])Inorder(tree[root][1]);
        if(tree[root][0])Inorder(tree[root][0]);
    } 
    if(tflag!=0)printf(" %d",pre[root]);
    else tflag=1,printf("%d",pre[root]);
}
int main(){
    scanf("%d",&N);
    for(int i=0;i<N;i++){
        scanf("%d",&pre[i]);
        if(i!=0)createTree(i,0);
    }
    if(Preorder(0)==false)printf("NO\n");
    else printf("YES\n"),Inorder(0);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值