【剑指紫金港】1153 Decode Registration Card of PAT

A 1153 Decode Registration Card of PAT

题目链接

Problem Description

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely,Tfor the top level, Afor advance and Bfor basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Typebeing 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Typebeing 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Typebeing 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output

For each query, first print in a lineCase #: input, where #is the index of the query case, starting from 1; and inputis a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Nswhere Ntis the total number of testees and Nsis their total score;
for a type 3 query, output in the format Site Ntwhere Siteis the site number and Ntis the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

解题思路

类型1创建T、A、B三个vector,存放三种类型的答案;类型2遍历信息数组,统计答案;类型3最复杂,遍历信息数组,统计对应日期下的所有Nt个数,用unordered_map存放和累加,然后将结果放到vector< node >中排序和输出。

AC代码

#include<bits/stdc++.h>
using namespace std;

struct node{
	string id;
	int score;
};

bool cmp(const node &a,const node &b){
	return a.score!=b.score ? a.score>b.score:a.id<b.id;
}

int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	vector<node> stu(n);
	vector<node> T;
	vector<node> A;
	vector<node> B;
	for(int i=0;i<n;i++){
		cin>>stu[i].id>>stu[i].score;
		if(stu[i].id[0]=='T'){
			T.emplace_back(stu[i]);
		}else if(stu[i].id[0]=='A'){
			A.emplace_back(stu[i]);
		}else{
			B.emplace_back(stu[i]);
		}
	}
	sort(T.begin(),T.end(),cmp);
	sort(A.begin(),A.end(),cmp);
	sort(B.begin(),B.end(),cmp);
	int type;
	string term;
	for(int i=1;i<=m;i++){
		cin>>type>>term;
		printf("Case %d: %d %s\n",i,type,term.c_str());
		if(type==1){
			if(term=="T"){
				for(int k=0;k<T.size();k++){
					printf("%s %d\n",T[k].id.c_str(),T[k].score);
				}
				if(T.size()==0){
					printf("NA\n");
				}
			}else if(term=="A"){
				for(int k=0;k<A.size();k++){
					printf("%s %d\n",A[k].id.c_str(),A[k].score);
				}
				if(A.size()==0){
					printf("NA\n");
				}
			}else{
				for(int k=0;k<B.size();k++){
					printf("%s %d\n",B[k].id.c_str(),B[k].score);
				}
				if(B.size()==0){
					printf("NA\n");
				}
			}
		}else if(type==2){
			int cnt=0,sum=0;
			for(int k=0;k<n;k++){
				if(stu[k].id.substr(1,3)==term){
					cnt++;
					sum+=stu[k].score;
				}
			}
			if(cnt==0){
				printf("NA\n");
			}else{
				printf("%d %d\n",cnt,sum);
			}
		}else{
			unordered_map<string,int>count;
			vector<node>ans;
			for(int k=0;k<n;k++){
				if(stu[k].id.substr(4,6)==term){
					count[stu[k].id.substr(1,3)]++;
				}
			}
			for(auto it:count){
				ans.push_back({it.first,it.second});
			}
			sort(ans.begin(),ans.end(),cmp);
			for(int k=0;k<ans.size();k++){
				printf("%s %d\n",ans[k].id.c_str(),ans[k].score);
			}
			if(ans.size()==0){
				printf("NA\n");
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值