【剑指紫金港】1040 Longest Symmetric String DP回文字符串

A 1040 Longest Symmetric String DP回文字符串

题目链接

Problem Description

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;
int dp[maxn][maxn];

int main(){
    string str;
    getline(cin,str);
    int maxl=1,len=str.size();
    //fill(dp[0],dp[0]+maxn*maxn,0);
    for(int i=0;i<len;i++){
        dp[i][i]=1;
        if(i<len-1 && str[i]==str[i+1]){
            dp[i][i+1]=1;
            maxl=2;
        }
    }
    for(int L=3;L<=len;L++){
        for(int i=0;i+L-1<len;i++){
            int j=i+L-1;
            if(str[i]==str[j] && dp[i+1][j-1]==1){
                dp[i][j]=1;
                maxl=L;
            }
        }
    }
    printf("%d",maxl);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值