More is better(记录最大节点)

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题意:
王老师想留下几个小同学陪他做项目,但是留下的这些小同学都得是朋友(直接或间接),问最多可以留下多少人,当输入0时,说明没有人相互之间是朋友,(这关系维持的不大行啊),那么就随便抓一个了,此时输出为1;

#include<iostream>
#include<cstdio>
using namespace std;
int pre[10000010],dep[10000010],ma=1;//dep来记录每组有多少个成员;pre来组成每个组;
int find(int root)
{
	if(root!=pre[root]) pre[root]=find(pre[root]);
	return pre[root];
}
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=10000001;i++)
	{
		pre[i]=i;
		dep[i]=1;
	}
	for(int i=1;i<=n;i++)
	{
		int a,b;
		cin>>a>>b;
		int f1=find(a),f2=find(b);
		if(f1!=f2)
		{
			pre[f1]=f2;
			dep[f2]+=dep[f1];
			if(dep[f2]>ma);//更新最大值;
			ma=dep[f2];
		}
	}
	printf("%d",ma);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值