HDU 4099 Revenge of Fibonacci(斐波那契数列+字典树)

Description


The well-known Fibonacci sequence is defined as following:

F(0) = F(1) = 1
F(n) = F(n - 1) + F(n - 2) (n >= 2)


  Here we regard n as the index of the Fibonacci number F(n).
  This sequence has been studied since the publication of Fibonacci's book Liber Abaci. So far, many properties of this sequence have been introduced.
  You had been interested in this sequence, while after reading lots of papers about it. You think there’s no need to research in it anymore because of the lack of its unrevealed properties. Yesterday, you decided to study some other sequences like Lucas sequence instead.
  Fibonacci came into your dream last night. “Stupid human beings. Lots of important properties of Fibonacci sequence have not been studied by anyone, for example, from the Fibonacci number 347746739…”
  You woke up and couldn’t remember the whole number except the first few digits Fibonacci told you. You decided to write a program to find this number out in order to continue your research on Fibonacci sequence.


Input


  There are multiple test cases. The first line of input contains a single integer T denoting the number of test cases (T<=50000).
  For each test case, there is a single line containing one non-empty string made up of at most 40 digits. And there won’t be any unnecessary leading zeroes.


Output


  For each test case, output the smallest index of the smallest Fibonacci number whose decimal notation begins with the given digits. If no Fibonacci number with index smaller than 100000 satisfy that condition, output -1 instead – you think what Fibonacci wants to told you beyonds your ability.


Sample Input


15
1
12
123
1234
12345
9
98
987
9876
98765
89
32
51075176167176176176
347746739
5610


Sample Output


Case #1: 0
Case #2: 25
Case #3: 226
Case #4: 1628
Case #5: 49516
Case #6: 15
Case #7: 15
Case #8: 15
Case #9: 43764
Case #10: 49750
Case #11: 10
Case #12: 51
Case #13: -1
Case #14: 1233
Case #15: 22374

给你一个字符串,求最小的斐波那契数的下标,使这个字符串是这个斐波那契数的前缀。

将0~99999斐波那契数存入字典树,只存前40位,然后查找。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
typedef unsigned long long ull;
using namespace std;

const int N=10;

int f1[65],f2[65],f3[65];

class Trie
{
public:
    int v;
    int flag;
    Trie *next[N];
    Trie()
    {
        v=-1;
        memset(next,NULL,sizeof(next));
    }
};

Trie *root;

void Insert(char *S,int ans)
{
    int len=strlen(S);
    Trie *p=root;
    for(int i=0; i<len; i++)
    {
        int id=S[i]-'0';
        if(p->next[id]==NULL)
            p->next[id]=new Trie();
        p=p->next[id];
        if(p->v<0)
            p->v=ans;
    }
}

int Find(char *S)
{
    Trie *p=root;
    int count;
    int len=strlen(S);
    for(int i=0; i<len; i++)
    {
        int id=S[i]-'0';
        p=p->next[id];
        if(p==NULL)
            return -1;
        else
            count=p->v;
    }
    return count;
}

void Init()
{
    int h;
    char str[65]="1";
    memset(f1,0,sizeof(f1));
    memset(f2,0,sizeof(f2));
    memset(f3,0,sizeof(f3));
    f1[0]=1;
    f2[0]=1;
    Insert(str,0);
    for(int i=2; i<100000; i++)
    {
        memset(str,0,sizeof(str));
        int r=0;
        for(int j=0; j<60; j++)
        {
            f3[j]=f1[j]+f2[j]+r;
            r=f3[j]/10;
            f3[j]%=10;
        }
        for(int j=59; j>=0; j--)
            if(f3[j])
            {
                h=j;
                break;
            }
        int k=0;
        for(int j=h; j>=0; j--)
        {
            str[k++]=f3[j]+'0';
            if(k>=40)
                break;
        }
        Insert(str,i);
        if(h>55)
        {
            for(int j=1; j<59; j++)
                f3[j-1]=f3[j];
            for(int j=1; j<59; j++)
                f2[j-1]=f2[j];
        }
        for(int j=0; j<60; j++)
            f1[j]=f2[j];
        for(int j=0; j<60; j++)
            f2[j]=f3[j];
    }
}

int main()
{
    root=new Trie();
    Init();
    char str[105];
    int t,i,j,k=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        printf("Case #%d: ",k++);
        int tmp=Find(str);
        printf("%d\n",tmp);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值