ZOJ3469 Food Delivery(区间dp)

3 篇文章 0 订阅

Description

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain BiDispleasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

 

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi>= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

 

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

 

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5
 

Sample Output

 

55

题意:

在x轴上有n个客人,每个客人每秒增加的愤怒值不同。给出客人和餐厅的位置,以及客人每分钟增加的愤怒值,和送餐行走一公里需要的时间,问送完n个客人的外卖最小愤怒值

 

思路:

把餐厅所在的点加进去,然后按照在x轴上的位置排序。从餐厅所在位置向左右开始DP

dp[i][j][0]表示从i到j用户送到最小不开心值,此时送货员停留在左边即i位置

dp[i][j][1]表示从i到j用户送到最小不开心值,此时送货员停留在右边即j位置

状态有四种,

            dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][0] + (a[i+1].x-a[i].x)*(sum[n]-sum[j]+sum[i]));
            dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][1] + (a[j].x-a[i].x)*(sum[n]-sum[j]+sum[i]));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][0] + (a[j].x-a[i].x)*(sum[n]-sum[j-1]+sum[i-1]));
            dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][1] + (a[j].x-a[j-1].x)*(sum[n]-sum[j-1]+sum[i-1]));

 

代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
struct node
{
    int x,b;
}no[1010];
int dp[1010][1010][2],sum[1010];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int n,v,st,ed;
    while(scanf("%d %d %d",&n,&v,&st)>0)
    {
        for(int i=0;i<n;i++)
        scanf("%d%d",&no[i].x,&no[i].b);
        no[n].x=st;
        no[n++].b=0;
        sum[0]=0;
        sort(no,no+n,cmp);
        for(int i=0;i<n; i++)
        {
            for(int j=0;j<n; j++)
                dp[i][j][0]=dp[i][j][1]=INF;
            if(no[i].x==st) ed=i;
            sum[i+1]=sum[i]+no[i].b;
        }
        dp[ed][ed][0]=dp[ed][ed][1]=0;
        for(int i=ed;i>=0; i--)
        {
            for(int j=ed;j<n;j++)
            {
                if(i==j)
                    continue;
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[i+1]+sum[n]-sum[j+1])*(no[i+1].x-no[i].x));
                dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[i+1]+sum[n]-sum[j+1])*(no[j].x-no[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(sum[i]+sum[n]-sum[j])*(no[j].x-no[i].x));
                dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(sum[i]+sum[n]-sum[j])*(no[j].x-no[j-1].x));
            }
        }
        printf("%d\n",min(dp[0][n-1][0],dp[0][n-1][1])*v);
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值