POJ——Parencodings

http://poj.org/problem?id=1068

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

这个题,第一眼看以为是括号匹配,但是他给的是数字,所以可以根据给的数字模拟出左括号和右括号

#include<iostream>

#include<stdio.h>

#include<string.h>
using namespace std;
int a[99],b[99],c[99];
int main()
{
	int n,t;
	cin >> t;
	while(t--){
		memset(b,0,sizeof(b));//清零 
		memset(c,0,sizeof(c));
		cin >> n;
		for(int i=1;i<=n;i++){
			cin >> a[i];
		}
		int k=1;
		a[0]=0;
		for(int i=1;i<=n;i++){//模拟 (的位置 
			for(int j=0;j<a[i]-a[i-1];j++){
				b[k++]=1;//(==1 
			}
			k++;
		}
		int sum=1;
		for(int i=1;i<k;i++){
			if(b[i]==0){//)==0 
				for(int j=i-1;j>=1;j--){//进行匹配  
					if(b[j]!=0){
						c[sum]++;//存数 
							if(b[j]==1){
								b[j]=99;//标记匹配过的数 
								sum++;
								break;
						}
					}
				}
			}
		}
		for(int i=1;i<sum;i++){
			cout << c[i] << " ";
		}
		 cout<<endl; 
	}
	return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值