hdu 1005 Number Sequence

Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3 1 2 10 0 0 0

Sample Output

2 5

http://acm.hdu.edu.cn/showproblem.php?pid=1005

解题思路

这题是一个需要找规律的题目,该题的求解中是存在循环节的,如果没有进行优化,无法避免超时超内存。

因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有49种可能值了。当连续的两项在前面出现过,就可以找到循环节。在50次循环中一定可以找到循环节。

#include<stdio.h>
int main()
{
    int a,b,n,f[57],i;
    f[1]=f[2]=1;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF)
    {
        if(a==0 && b==0 && n==0)
            break;
        for(i=3;i<50;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==1&&f[i-1]==1)//如果有两个连着 =1,则后面的全部和前面相同,即出现了周期,跳出循环, 周期为i-2
            {
                break;
            }
        }
        n=n%(i-2);// 把n对周期求模
        f[0]=f[i-2];
        printf("%d\n",f[n]);
    }
    return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值