PTA甲级 1051 Pop Sequence (C++)

Given a stack which can keep M M M numbers at most. Push N N N numbers in the order of 1, 2, 3, …, N N N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M M M is 5 and N N N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M M M (the maximum capacity of the stack), N N N (the length of push sequence), and K K K (the number of pop sequences to be checked). Then K K K lines follow, each contains a pop sequence of N N N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-15 23:34:06
// All rights reserved.

#include <iostream>
#include <vector>
#include <stack>

using namespace std;

int main(){
    int m, n, k;
    // m : the maximum capacity of the stack
    // n : the length of push sequence
    // k : the number of pop sequences to be checked

    scanf("%d %d %d", &m, &n, &k);

    vector<vector<int>> toCheck(k, vector<int>(n));

    for(int i = 0; i < k; ++i){
        for(int j = 0; j < n; ++j) scanf("%d", &toCheck[i][j]);
    }

    
    for(int i = 0; i < k; ++i){
        int lastOut = 0;
        stack<int> s;
        int j;

        for(j = 0; j < n; ++j){

            if(toCheck[i][j] > lastOut){

                for(int p = lastOut + 1; p <= toCheck[i][j]; ++p) s.push(p);
            
                if(s.size() > m){
                    printf("NO\n");
                    break;
                }

                s.pop();
                lastOut = toCheck[i][j];
            }
            else if(toCheck[i][j] < lastOut){
                if(toCheck[i][j] != s.top()){
                    printf("NO\n");
                    break;
                }
                else s.pop();
            }
        }

        if(j == n) printf("YES\n");
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值