PTA甲级 1040 Longest Symmetric String (C++)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-16 15:43:11
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    string s;
    getline(cin, s);
    int len = s.length();

    vector<vector<bool>> dp(len, vector<bool>(len, false));
    int ans = 1;


    for(int L = 0; L < len; ++L){

        for(int i = 0; i < len - L; ++i){
            if(L == 0){
                dp[i][i] = true;
                continue;
            }

            int j = i + L;

            if(s[i] == s[j]){
                if(L <= 2) dp[i][j] = true;
                else dp[i][j] = dp[i + 1][j - 1];

                if(dp[i][j] == true && ans < L + 1) ans = L + 1;
            }
            else dp[i][j] = false;

        }
    }

    printf("%d\n", ans);

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值