PTA甲级 1061 Dating (C++)

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

Caution:

这个题的描述有问题!
这个题的描述有问题!
这个题的描述有问题!

对于小时的解释有问题,题目里面说:

the second common character is the 5th capital letter E

我没翻译错的话就是

第二个共同的字符是第五个大写字母E…

但显然不是啊!!!!
大家看样例输入,第一个字符串和第二个字符串的第二个共同的字符明明是D(和星期四那个同一个D),而第一个是位于第二个位置(从零开始计数)的8,因为题目里明确说明是第二个相同的“字符”,所以数字和字母都应该算的。

所以我觉得这个题他自己都没说明白规则。。。。。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-19 17:45:01
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

string days[7] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};

int main(){
    string a, b, c, d;
    cin >> a >> b >> c >> d;

    int day, hour, minute;
    
    day = 0;
    while(true){
        if(a[day] == b[day] && 'A' <= a[day] && 'G' >= a[day]) break;
        day++;
    }

    hour = day + 1;
    while(true){
        if(a[hour] == b[hour] && (isdigit(a[hour]) || (a[hour] >= 'A' && a[hour] <= 'N'))) break;
        hour++;
    }

    minute = 0;
    while(true){
        if(c[minute] == d[minute] && isalpha(c[minute])) break;
        minute++;
    }

    printf("%s %02d:%02d\n", days[a[day] - 'A'].c_str(), a[hour] <= '9' ? a[hour] - '0' : a[hour] - 'A' + 10, minute);

    return 0; 
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值