PTA甲级 1129 Recommendation System (C++)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user’s preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N ( ≤ 50 , 000 ) N (≤ 50,000) N(50,000), the total number of queries, and K ( ≤ 10 ) K (≤ 10) K(10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing – for the sake of simplicity, all the items are indexed from 1 to N N N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, … K K K) is the i-th item that the system recommends to the user. The first K K K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

Caution:

排序那一部分理论上来说用插入排序应该会比快排效果好一些,代码里面被注释掉的是调用快排,结果提交上去后差别不大。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-28 17:38:14
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
#include <cmath>

using namespace std;

unordered_map<int, int> times;

bool cmp(int a, int b){
    if(times[a] != times[b]) return times[a] > times[b];
    else return a < b;
}

int main(){
    int n, k, tmp, lastIn;
    scanf("%d %d", &n, &k);
    vector<int> showList;
    
    unordered_map<int, bool> isShown;

    for(int i = 0; i < n; ++i){
        if(i == 0){
            scanf("%d", &lastIn);
            continue;
        }

        scanf("%d", &tmp); 
        times[lastIn]++;

        if(isShown[lastIn] == true){
            int pos = find(showList.begin(), showList.end(), lastIn) - showList.begin();

            for(int j = pos; j > 0; --j){
                if(times[showList[j]] > times[showList[j - 1]]) swap(showList[j], showList[j - 1]);
                else if(times[showList[j]] == times[showList[j - 1]] && showList[j - 1] > showList[j]) swap(showList[j], showList[j - 1]);

                else break;
            }

            // sort(showList.begin(), showList.end(), cmp);
        }

        else{
            if(showList.size() < k){
                isShown[lastIn] = true;
                showList.push_back(lastIn);

                for(int j = showList.size() - 1; j > 0; --j){
                    if(times[showList[j]] > times[showList[j - 1]]) swap(showList[j], showList[j - 1]);
                    else if(times[showList[j]] == times[showList[j - 1]] && showList[j - 1] > showList[j]) swap(showList[j], showList[j - 1]);

                    else break;
                }

                // sort(showList.begin(), showList.end(), cmp);
            }
            else{
                if(times[lastIn] > times[showList[k - 1]]){
                    isShown[showList[k - 1]] = false;
                    isShown[lastIn] = true;
                    showList[k - 1] = lastIn;

                    for(int j = k - 1; j > 0; --j){
                        if(times[showList[j]] > times[showList[j - 1]]) swap(showList[j], showList[j - 1]);
                        else if(times[showList[j]] == times[showList[j - 1]] && showList[j - 1] > showList[j]) swap(showList[j], showList[j - 1]);

                        else break;
                    }

                    // sort(showList.begin(), showList.end(), cmp);
                }

                else if(times[lastIn] == times[showList[k - 1]] && showList[k - 1] > lastIn){
                    isShown[showList[k - 1]] = false;
                    isShown[lastIn] = true;
                    showList[k - 1] = lastIn;

                    for(int j = k - 1; j > 0; --j){
                        if(times[showList[j]] > times[showList[j - 1]]) swap(showList[j], showList[j - 1]);
                        else if(times[showList[j]] == times[showList[j - 1]] && showList[j - 1] > showList[j]) swap(showList[j], showList[j - 1]);

                        else break;
                    }

                    // sort(showList.begin(), showList.end(), cmp);
                }
            }
        }

        printf("%d: ", tmp);
        for(int j = 0; j < min(k, (int)showList.size()); ++j){
            if(j == min(k, (int)showList.size()) - 1) printf("%d\n", showList[j]);
            else printf("%d ", showList[j]);
        }
        lastIn = tmp;
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值