PTA甲级 1138 Postorder Traversal (C++)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 50 , 000 ) N (≤ 50,000) N(50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

Caution:

找【后序遍历的第一个节点】的过程:一直往下走,如果有左孩子就顺着左孩子往下走,如果没有左孩子但有右孩子就顺着右孩子往下走,一直走到第一个没有左孩子也没有右孩子的节点,则这个节点就是后序遍历输出的第一个节点。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-29 16:48:19
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int preOrder[50005], inOrder[50005];
int n; 

int main(){
    scanf("%d", &n);

    for(int i = 0; i < n; ++i) scanf("%d", &preOrder[i]);
    for(int i = 0; i < n; ++i) scanf("%d", &inOrder[i]);

    int l1 = 0, l2 = 0, r1 = n - 1, r2 = n - 1;
    int thisNum = preOrder[0];

    while(true){
        if(l1 == r1){
            printf("%d\n", thisNum);
            break;
        }

        // 一定有孩子
        int posInPre = find(preOrder + l1, preOrder + r1 + 1, thisNum) - preOrder;
        int posInMid = find(inOrder + l2, inOrder + r2 + 1, thisNum) - inOrder;

        if(posInMid == l2){
            // 没有左孩子,只有右孩子
            thisNum = preOrder[posInPre + 1];
            l1++;
            l2++;
        }
        else{
            // 有左孩子
            thisNum = preOrder[posInPre + 1];
            r1 = l1 + posInMid - l2;
            r2 = posInMid - 1;
            l1++;
        }
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值