PTA甲级 1119 Pre- and Post-order Traversals (C++)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 30 ) N (≤ 30) N(30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-26 18:51:21
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

int n;
vector<int> preOrder, postOrder, inOrder;
bool isUnique = true;
unordered_map<int, bool> flags;

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k = -1){
        key = k;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

void findChildren(Node *root){
    if(root == NULL) return;

    int posInPre = find(preOrder.begin(), preOrder.end(), root -> key) - preOrder.begin();
    int posInPost = find(postOrder.begin(), postOrder.end(), root -> key) - postOrder.begin();

    int left = -1, right = -1;

    if(posInPre < n - 1 && !flags[preOrder[posInPre + 1]]) left = preOrder[posInPre + 1];
    if(posInPost > 0 && !flags[postOrder[posInPost - 1]]) right = postOrder[posInPost - 1];

    if(left != -1 && right != -1 && left == right){
        isUnique = false;
        flags[left] = true;
        root -> left = new Node(left);
    }
    else {
        if(left != -1){
            root -> left = new Node(left);
            flags[left] = true;
        }
        if(right != -1){
            root -> right = new Node(right);
            flags[right] = true;
        }
    }

    findChildren(root -> left);
    findChildren(root -> right);
} 

void inOrderTraverse(Node* root){
    if(root -> left != NULL) inOrderTraverse(root -> left);
    inOrder.push_back(root -> key);
    if(root -> right != NULL) inOrderTraverse(root -> right);
}

int main(){

    scanf("%d", &n);

    preOrder.resize(n);
    postOrder.resize(n);
    inOrder.clear();

    for(int i = 0; i < n; ++i) scanf("%d", &preOrder[i]);
    for(int i = 0; i < n; ++i) scanf("%d", &postOrder[i]);

    Node *root = new Node(preOrder[0]);
    flags[root -> key] = true;
    findChildren(root);

    inOrderTraverse(root);

    if(isUnique) printf("Yes\n");
    else printf("No\n");

    for(int i = 0; i < n; ++i){
        if(i == n - 1) printf("%d\n", inOrder[i]);
        else printf("%d ", inOrder[i]);
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值