PTA甲级 1095 Cars on Campus (C++)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N ( ≤ 1 0 4 ) N (≤10^4) N(104), the number of records, and K ( ≤ 8 × 1 0 4 ) K (≤8×10^4) K(8×104) the number of queries. Then N N N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K K K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

Caution:

这个题除了本身就够复杂了之外,还有两个比较容易错的地方:

  • 无效的 in 和 out 是不能参加校园里车辆数目的计算的,所以我在输入所有数据后还遍历了两遍(一遍从前往后,一遍从后往前)来筛掉无效的 in 和 out;
  • 在校园内的停车时间是要累积的,例子中的 JH007BD 的停车时间就是由两段加起来的。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-03 10:50:37
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>

using namespace std;

struct Event{
    string time;
    int hour, minute, second;

    int isQuery = -1;
    string ID;
    bool in;
    bool valid;

    Event(string id, string t, bool i){
        ID = id;
        time = t;
        in = i;
        isQuery = 0;
        valid = true;

        hour = stoi(time.substr(0, 2));
        minute = stoi(time.substr(3, 2));
        second = stoi(time.substr(6, 2));
    }

    Event(string t){
        time = t;
        isQuery = 1;
        valid = true;

        hour = stoi(time.substr(0, 2));
        minute = stoi(time.substr(3, 2));
        second = stoi(time.substr(6, 2));
    }

    ~Event(){}
};

bool cmp(Event &a, Event &b){
    if(a.time!= b.time) return a.time < b.time;
    return a.isQuery < b.isQuery;
}

int main(){
    int n, k;
    scanf("%d %d\n", &n, &k);

    vector<Event> events;
    for(int i = 0; i < n; ++i){
        string tmp;
        getline(cin, tmp);
        string ID = tmp.substr(0, 7);
        string time = tmp.substr(8, 8);
        bool in = (tmp.length() == 19);

        events.emplace_back(ID, time, in);
    }

    for(int i = 0; i < k; ++i){
        string tmp;
        cin >> tmp;

        events.emplace_back(tmp);
    }

    sort(events.begin(), events.end(), cmp);

    unordered_map<string, bool> inCampus;
    for(int i = 0; i < n + k; ++i){
        if(events[i].isQuery == 1) continue;

        if(events[i].in) inCampus[events[i].ID] = true;
        else{
            if(!inCampus[events[i].ID]) events[i].valid = false;
            else inCampus[events[i].ID] = false;
        }
    }

    inCampus.clear();
    for(int i = n + k - 1; i >= 0; --i){
        if(events[i].isQuery == 1 || !events[i].valid) continue;

        if(!events[i].in) inCampus[events[i].ID] = true;
        else{
            if(!inCampus[events[i].ID]) events[i].valid = false;
            else inCampus[events[i].ID] = false;
        }
    }

    int carsOnCampus = 0;
    int longestTime = -1;
    vector<string> longestIds;
    unordered_map<string, string> inTime;
    unordered_map<string, int> periodTime;

    for(int i = 0; i < n + k; ++i){
        if(events[i].isQuery == 1) printf("%d\n", carsOnCampus);
        else{
            if(!events[i].valid) continue;

            string tmpID = events[i].ID;

            if(events[i].in){
                inTime[tmpID] = events[i].time;
                carsOnCampus++;
            }
            else{
                int inHour = stoi(inTime[tmpID].substr(0, 2));
                int inMinute = stoi(inTime[tmpID].substr(3, 2));
                int inSecond = stoi(inTime[tmpID].substr(6, 2));

                int timeLen = events[i].hour * 3600 + events[i].minute * 60 + events[i].second - (inHour * 3600 + inMinute * 60 + inSecond);

                periodTime[events[i].ID] += timeLen;
                if(periodTime[events[i].ID] > longestTime) longestTime = periodTime[events[i].ID];

                inTime[tmpID] = "";
                carsOnCampus--;
            }
        }
    }
    
    for(auto it = periodTime.begin(); it != periodTime.end(); ++it){
        if(it -> second == longestTime) longestIds.push_back(it -> first);
    }

    sort(longestIds.begin(), longestIds.end());
    for(int i = 0; i < longestIds.size(); ++i) printf("%s ", longestIds[i].c_str());

    printf("%02d:", longestTime / 3600);
    longestTime %= 3600;
    printf("%02d:", longestTime / 60);
    longestTime %= 60;
    printf("%02d\n", longestTime);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值