Cat and fish[模拟]ICPC Beijing E

21 篇文章 0 订阅

#1631 : Cats and Fish

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

输入

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

输出

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

样例输入

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1

样例输出

1 0
0 1
0 3
#include<iostream>
#include<cstring>
#include<string>
#include<vector>
#include <algorithm>
using namespace std;
int c[110],b[110];
int main()
{
    int m,n,x;
    while(scanf("%d %d %d",&m,&n,&x)!=EOF)
    {
        memset(c,0,sizeof(c));
        memset(b,0,sizeof(b));
        vector<pair<int,int>>v;
        v.clear();
        for(int i=0;i<n;i++)
        {
            scanf("%d",&c[i]);
        }
        for(int j=1;j<=x;j++)
        {
            int t=0;
            for(int i=0;i<n;i++)
            {
                if(b[i]==0)
                    t++;
            }
            if(t>m)
            {
                v.clear();
                for(int i=0;i<n;i++)
                {
                    if(b[i]==0)
                    {
                        v.push_back({c[i],i});
                    }
                }
                sort(v.begin(),v.end());
                for(int i=0;i<v.size();i++)
                {
                    if(m<=0)
                        break;
                    m--;
                    b[v[i].second]=c[v[i].second];
                }
            }
            else
            {
                for(int i=0;i<n;i++)
                {
                    if(b[i]==0)
                    {
                        m--;
                        b[i]=c[i];
                    }
                }
            }
            for(int i=0;i<n;i++)
            {
                b[i]--;
            }
        }
        int r=0;
        for(int i=0;i<n;i++)
        {
            if(b[i]>0)
            {
                r++;
                //cout<<"  i"<<i<<endl;
                //cout<<"  b[i]"<<b[i]<<endl;
            }
        }
        printf("%d %d\n",m,r);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值