记录一下自己的蠢事

先看一下原题:
pta 7-2
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

题目并不难, 但也架不住我蠢啊

用char数组存储了前中遍历序列,
然后把值赋给了int类型的data

下面是正确代码

#include <iostream>
#include<queue>

using namespace std;

struct BinNode
{
    int data;
    BinNode* lc;
    BinNode* rc;
    BinNode() : lc ( NULL ), rc ( NULL ) {}
    BinNode ( int _data ) : data ( _data ), lc ( NULL ), rc ( NULL ) {}
};

BinNode* rebuild ( int length, int *pre, int*in )
{
    if ( length == 0 )
        return NULL;

    int i;
    BinNode *r = new BinNode;
    r->data = pre[0];

    for ( i = 0; i < length; i ++ )
    {
        if ( pre[0] == in[i] )
        {
            break;
        }
    }
    //cout<<r->data<<" ";
    r->lc = rebuild ( i, pre + 1, in );
    r->rc = rebuild ( length - i - 1, pre + i + 1, in + i + 1 );
    return r;
}

void levelTran ( BinNode* root)
{
    queue<BinNode* > q;
    q.push ( root );
    while ( !q.empty() )
    {
        BinNode* temp = q.front();
        q.pop();
        cout << temp->data;
        if(!q.empty())
        	cout<<" ";
        if(lim++ < length)
        	cout<<" ";
        if ( temp->rc )
            q.push ( temp->rc );
        if ( temp->lc )
            q.push ( temp->lc );
    }
}

int main()
{
    int length;
    cin >> length;
    if ( length > 30 )
        return 0;
    int in[length];
    int pre[length];
    for ( int i = 0; i < length; i++ )
    {
        cin >> in[i];
    }
    for ( int i = 0; i < length; i++ )
    {
        cin >> pre[i];
    }

    BinNode* root;
    root = rebuild ( length, pre, in );

    levelTran(root);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值