1046 Shortest Distance (思维题)

1046 Shortest Distance (20分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

题意:

找到环形路径两点之间的最短距离。

#include<iostream>
#include<algorithm>
using namespace std;
long long a[100000];
int main(){
	long long n;
	long long sum=0;
	cin>>n;
	// 求出来每个节点到达零点的距离 
	for(int i=1;i<=n;i++){
		cin>>a[i];
		sum+=a[i]; 
		a[i]=sum-a[i]; 
	}
	long long m;
	cin>>m;
	while(m--){
		long long h,e;
		cin>>h>>e;
		if(h>e)swap(h,e);
		// 将两个点到达1点的距离相减得到两点之间的距离。 
		long long ans=a[e]-a[h];
		// 因为是个环形路径所以可以用sum-ans 可以得到逆向距离。 
		if(sum-ans>ans)cout<<ans<<endl;
		else cout<<sum-ans<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值