WEEK 15 A ZJM 与霍格沃兹

题目

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

Input

首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

思路

将魔咒与对应功能保存到数组中,使用map<unsigned,int>来记录字符串哈希值与数组下标。
对于要查询的字符串,求取其哈希值并在map中查找,若存在则输出对应下标的字符串,否则输出“what?”。

代码

#include <iostream>
#include <cstring>
#include <string>
#include <string.h>
#include <map>

using namespace std;

const int maxn = 1000005;
const int seed = 7;
char s1[maxn][25], s2[maxn][85];
int cnt;
map<unsigned, int> mp;

unsigned Hash(string s) 
{
	unsigned int thehash = 0;
	for (int i = 0; i < s.size(); i++)
		thehash = thehash * seed + (unsigned)(s[i]);
	return thehash;
}

void split(string s) 
{
	string s3, s4;
	for (int i = 1; i < s.size(); i++) 
	{
		if (s[i] == ']') 
		{
			s3 = s4;
			s4.clear();
			i++;
			continue;
		}
		s4 += s[i];
	}
	cnt++;
	mp[Hash(s3)] = cnt; 
	strcpy(s1[cnt], s3.c_str());
	mp[Hash(s4)] = cnt; 
	strcpy(s2[cnt], s4.c_str());
}

void find(string s) 
{
	if (s[0] == '[') 
	{
		string thes; 
		thes.clear();
		for (int i = 1; i < s.size() - 1; i++)
			thes += s[i];
		unsigned thehash = Hash(thes);
		if (mp[thehash] == 0) 
		{
			printf("what?\n");
			return;
		}
		printf("%s\n", s2[mp[thehash]]);
		return;
	}
	else 
	{
		unsigned thehash = Hash(s);
		if (mp[thehash] == 0) 
		{
			printf("what?\n");
			return;
		}
		printf("%s\n", s1[mp[thehash]]);
		return;
	}
}

int main() 
{
	while (true) 
	{
		string s;
		getline(cin, s);
		if (s == "@END@") 
			break;
		split(s);
	}
	int n; 
	scanf("%d", &n);
	getchar();
	while (n--) 
	{
		string s; 
		getline(cin, s);
		find(s);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值