poj3984-迷宫问题

Description
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
该题运用bfs进行遍历,确保每一条可能的路都走过,同时还要记录步骤,运用设置前驱的方法进行记录,
1.进行广度遍历,因为一个前驱可能有多个后继,把他的每一个后继找出之后再进行遍历
2.遍历之后进行标记,防止重复遍历
3.设置两个数字进行记录每一个点的排名,rear代表当前的点,front 代表rear的前驱,当前驱等于后继的时候跳出,遍历结束
3.输出,运用递归,当前驱为-1的时候进行回溯,输出
代码如下

#include<iostream>
using namespace std;
int a[5][5];
int disx[4]={-1,0,1,0};
int disy[4]={0,1,0,-1};//可以走的路径 
struct node{
	int x,y,pre;
}q[50];//存放位置,前驱 
int front=0;
int rear=0;//rear为队尾加进的元素,front为rear的前驱,便于回溯的时候找到 
int vis[5][5];
void bfs()
{
	q[0].x=0,q[0].y=0,q[0].pre =-1;//将0入队 
	rear+=1;//队里有一个元素 
	vis[0][0]=1;//标记 
	while(front<rear)//当队列里始终有元素时进行循环 
	{
		for(int i=0;i<4;i++)//四个方向遍历 
		{
			int newx=q[front].x+disx[i];
			int newy=q[front].y+disy[i];
			if(newx<0||newx>4||newy<0||newy>=5||a[newx][newy]==1||vis[newx][newy]==1)
				continue;//不满足条件时跳过 
			q[rear].x=newx;
			q[rear].y=newy;
			q[rear].pre=front;//进入队列 
			rear++;//队首加1 
			vis[newx][newy]=1;//标记 
			if(newx==4&&newy==4)
				return ;//结束条件 
		}
		front++;//队尾加1 
	}
}
void print(node a)
{
	if(a.pre==-1)
		cout<<"("<<a.x<<","<<" "<<a.y<<")"<<endl;
	else
	{
		print(q[a.pre]);
		cout<<"("<<a.x<<","<<" "<<a.y<<")"<<endl;
	}
}
int main()
{
	for(int i=0;i<5;i++)
		for(int j=0;j<5;j++)
		{
			cin>>a[i][j];
		}
	bfs();
	print(q[rear-1]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值